Mac Stopped Recognizing Yosemite Boot Partition

Last night, my mac was booted on my Yosemite partition. I left it off the charger accidentally and it died. No big deal, right? So after plugging it in and turning it on again, it boots right to my Snow Leopard partition. Not uncommon, I forgot to hold down option to select the disk. When I restarted and held option, nothing came up and it went immediately to Snow Leopard. I tried command + option + r, option + r, command + option + r, nothing worked. Went to System Preferences, and my Yosemite partition isn’t available to be selected as the start up disk. My computer still recognizes the partition in Disk Utility, and I can access all the files on the drive. I repaired and verified the disks in Disk Utility just to see if that would help, but no luck. I just can’t boot to it. Any ideas?

it is worth mentioning I recently spilt a small small bit of water on my keyboard, leading to a few keys not working anymore (they weren’t keys that were even close to the spill?). However, my command, r, option, and p keys are all unaffected and working properly.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment