Ir para o conteúdo principal

The Samsung Gear S3 is the third-generation Samsung Gear smartwatch, first released in November of 2016. Features a round OLED display running the Tizen OS. Model number: SM-R770NZSAXAR.

67 Perguntas Visualizar todos

Won't Turn on After Replacing Battery

I replace the battery on my Gear S3 Classic. I followed some video and had no issues. I've dealt with this kind of stuff before.

The charging screen comes on when I place it on the charger and it seems to react when I push the back button. I mention this because it doesn't do anything at all when I hold down the "Home" / power button.

I've researched a good amount and saw that some people have success with holding both buttons, holding the Home for 10 seconds, and of course checking all of the connectors. I have also tried using the original battery.

Of course, I've had no luck with any of these. My current guess is that the home button is not working anymore for some reason.

Has anyone had this issue and if so how did you fix it?

If not that, could someone link me a resource to learn more about the insides of the watch so I can continue troubleshooting it?

Thank you!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 4

3 comentários:

I'm in the same boat and seems to be a common theme yet years later still no one has an answer. After fiddling around and trying to clean every connector, I broke the power flex cable. I'm going to try to replace that as well, and see if that has any effect. Anyone else had any luck?


For some reason I only see people having this problem with the gear s3 classic.

I have the exact same problem. I guess I'm going to try and put the old battery back in. If I find a solution, which is unlikely as no one has for the past 5 years of formums I found, I will post it.


Just curious is it the motherboard issue? Because I facing the same issue as well. Look online trying to buy 1 motherboard to try changing it


Adicionar um comentário

2 respostas

Maybe the new battery is damaged. Try installing the old one and tell me if it works.

Esta resposta foi útil?

Pontuação 0

6 comentários:

Bought two at the start and neither work. I'm going to attempt cleaning the connections.


Does the power button show any response at all? I'm not sure exactly which one is the power button but I recommend making sure these batteries have at least 3.7 Volts via measuring with a digital multimeter if possible.

I've replaced a battery for a Gear S3 Classic which essentially is the same as this one and it worked great.


There is no response at all from the power button.


2 weeks ago I replaced the battery in my S3 Frontier watch and initially it said the battery was at 61%. After 30-45 min I found it with an overheating error and immediately I removed it from the charging station. Frustrated, I ordered another battery and yesterday I replaced the battery. When I put it on the charger it said 17%, This morning when I pressed the power button, nothing happened. So I pressed both buttons and immediately it wanted to switch over to power-saving mode. When I put it back on the charging station it said 1%. Now I'm wondering what I am doing wrong. I should mention that the glass on the back of the watch is broken and for $29.00 I ordered the replacement. Any thoughts or suggestions are welcome.


I have the same problem. After replacing the battery and charging, the screen showed that it went from 62% to 100%. So the screen seems to work, but it won't turn on. The power on button is my guess as well.


Exibir mais 1 comentário

Adicionar um comentário

Anyone had try to change the motherboard?

Esta resposta foi útil?

Pontuação 0

1 comentário:

Hi, did you find a solution? I have the same problem.


Adicionar um comentário

Adicionar a sua resposta

Steven Hawley será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 11

Últimos 30 dias: 61

Duração total: 2,874