No touch function after backlight repair (Advanced!)

Hi, this is my first question here.

I own a repair shop and do repairs on iPhone's for at last 3 years.

Now i got a iPhone 6s that drives me CRAZY!!!

A customer brought it in for a backlight damage, as always i checked the FL4211 for damage, none to bee seen also no burning, after i took of the CPU shield and the D4021 was a bit raised so i replaced it, after that the backlight came on and worked like a charm.

BUT, after the initial boot, the image on the screen was full of a pattern i have seen before, namely when you turn on a iPhone 6/6plus without the U2402 on. Vertical lines with some kind of checkered pattern.

I replaced 3 screens, cleaned the FPC, restored with latest os, nothing changed.

After i measured the "PP1V8_TOUCH_CONN" and here i found a open circuit, i made a strap on the "FL4209" and after that everything was in order with that line.

Still no touch function, i measured the following lines:

  • "SPI_AP_TO_TOUCH_CS_L";
  • "SPI_AP_TO_TOUCH_SCLK";
  • "SPI_AP_TO_TOUCH_MOSI";
  • "SPI_TOUCH_TO_AP_MISO";
  • "TOUCH_TO_AP_INT_L";
  • "AP_TO_TOUCH_CLK32K_RESET_L".

All of them give me a ~0.420V voltage drop to ground, no open circuit on any of them!

Also i mesured the "PP5V1_TOUCH_VDDH" when the phone was on and i got the 5.1V on that line.

I cannot understand what the problem is? Where am i missing something? There is no mechanical damage to the board, all SMD parts are in the right places.

Maybe someone has a ideea...

Thanks in advance.

D.

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3 Soluções

Solução escolhida

Have you checked the Chestnut circuit? Beyond the 5V1 line, there is also the PP5V7_MESON_AVDDH

& PN5V7_LCM_MESON_AVDDN. There is also the PP1V8_TOUCH (Fl4209) line which also powers the touch functionality.

I would also check the AP_TO_TOUCH_RESET_L line (FL4134). Then there is the LCM_TO_OWL_BSYNC line (FL4230). There are lot's of Touch lines on page 42 of the schematic.

Esta resposta foi útil?

Pontuação 2
Adicionar um comentário

Hi,

I have done some iPhone board work but I still don't know much but I know what if you search up STS telecom on Youtube he does lots of these problems. It's worth having a look.

Hope that helped

Esta resposta foi útil?

Pontuação 0

Comentários:

Thank you but still did not find a solution to my problem...

por

Adicionar um comentário

in my case i checked SPI_TOUCH_TO_AP_MISO and no value checked on another working board and there is a testpoint next to the cpu i could run a jumper from but my bord dont have value on the testpoint either so the last point is inside CPU so am stuck at this point

Block Image

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Dacian Bujor será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 3

Últimos 7 dias: 11

Últimos 30 dias: 33

Todo: 305