Ambient light sensor not working

I purchased and installed an ifixit screen for my iPhone 6s, and the 3D Touch feature was so sensitive you couldn't use it, and the auto brightness would not work. If you set the brightness and locked the phone, it came back on at medium brightness every time. I received a replacement screen, and the 3D Touch works great, but the ambient light sensor is still not working. Same issue with the brightness returning at 50% regardless of where you set it. I got the screen and digitizer as an assembly so the accessories (other than the home button) were already installed. All other features including the proximity sensor and front camera work fine. Help!

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 2
Adicionar um comentário
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3 Soluções

Solução escolhida

Try replacing the front camera flex with the original one from your broken screen. Use this guide.

Esta resposta foi útil?

Pontuação 2

Comentários:

Thanks Minho. Unfortunately I don't have the original. I should have scavenged the original for parts but I put too much faith in the replacement!

por

This solution DOES NOT WORK!!

I purchased an iFixit replacement screen, and even after replacing the front camera flex with the original, it still does not work.

The iOS is detecting that the screen is NOT ORIGINAL and disables the Auto Brightness feature.

por

Adicionar um comentário

Well.... unfortunately i have the same problem. But it shouldn`t be the general doing for each display replacement. Luckily i have the original parts. :-/

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I have the same issue and I also can‘t use the old cable(Microphone is Brocken). I ordered 10 cable from different shops and all is workout only the ambient light. Still little under middle level. If I plug in temporarily the original it works fine. It seems a calibration is needed but all tutorials what I find didn’t work. If someone has a solution, please share it. Thanks

Greetings from Germany

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

dusty Wall será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 2

Últimos 30 dias: 16

Todo: 1,363