Ir para o conteúdo principal

Repair guides and support for phones manufactured by Caterpillar.

27 Perguntas Visualizar todos

CAT S61 only shows low battery screen upon start

I bought a used and defective Cat S61 thinking I could repair it. The problem: When starting the phone it shows the Android/Cat logo and shortly afterwards a battery low screen (low empty battery symbol that is crossed out). When connecting a cable it does the same in a loop (starting, Cat logo, battery low, turning off, starting again, …)

What I already tried/found out:

  1. The battery seems to be charged, it has 3.82 V.
  2. The battery has 4 pins, the two non-supply pins seem to have no electrical connection (Megaohms resistance) to each other, so it doesn’t seem to be a thermistor (or a broken one). I suppose it’s more likely the battery has an internal protection circuit and this is a communication port.
  3. I can’t even get into recovery, it immediately goes to the battery low screen and turns off. Hard reset is impossible.
  4. Charging port looks good
  5. Running the phone via cable and without battery does not work. It very shortly turns on the screen and immediately turns off again.

Since replacement batteries are a bit expensive for this phone I’m wondering if replacing the battery could likely fix this or if the battery is okay and the problem lies with the phone (meaning I likely can’t fix it).

Anyone had a similar problem? Anything else I could try?


Edit 1 week later: Directly supplying the phone battery plugs with power from a lab supply did not work. Charging the battery outside of the phone worked but didn’t help with the issue. A new battery did not fix the issue.

Edit 2: I found someone else who bought the phone from me and promised to tell me the fix in case they successfully repair it.

In case they tell me I will post the answer here.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 4
6 comentários

Not sure what the issue is but I’d consider buying it off you


@tech_ni This is not what I'm after at the moment but thanks for the offer. Maybe I will get back to you if I can't fix it.


How big is the charging brick? This probably won’t solve your issue but a beefier brick 5000mah< Might get you to power it on without the battery.


@areeve The biggest one I have (and the one I tried since I didn't get the original charger) is 5V/4A.

I also tried connecting my lab supply to the power pins of the phone battery connector to run it without a battery but it's the same as running it without battery from USB. It vibrates shortly, the screen turns on for less than a second without showing anything yet and the phone immediately turns off.

Maybe it needs some checks from the battery and doesn't even turn on briefly if that's missing.


I have the exact same issue with my cat s61.


Exibir mais 1 comentário

Adicionar um comentário

2 respostas

Pergunta mais útil

Hello @fivefold before you start investing money in either

a) A ***Replacement Battery*** b) A ***Charging Cable Flex Assembly***

There was a Charging Issue with a Caterpillar S61 a while ago reported by @cambriajean . @Jayeff was kind enough to share some guidance and insights on that case . Maybe they could update how that “FIX” went in the end??

You can review their thread, it is here . Thanks to our community contributors for that!

If you have the necessary tools to think about replacing the battery and if the Cat S61 device is open? (your not using it obviously!)

  • Consider trying to bypass the Existing Battery, the USB port and the Flex Assembly and probe 3.7V - 3.85Vdc (current limited) directly onto the battery flex connector terminals on the phone engine side from a known good battery or a power supply. NOT directly from a 5Vdc charger or a Power bank 5Vdc
  • That will check if the phone engine boots up. Then you know at least that there is some life in there still and it is worth thinking about investing in the spare parts?
    • I have done this for many devices before, especially with wireless charging devices . I could try to dig out a picture if it makes it clearer
    • BUT - I’m pretty sure the phone engine is ok. This would just serve as a process of narrowing down where the problem is and reducing the risk of buying a component that will be wasted. We also know something is going on for sure on the phone side from your shared picture and that the display works
  • Not everyone knows how to do such “Hacking” and “Debugging” (Yet!) or has a power supply even ……
  • So, Hazarding a guess, and from the most purchased spare parts for the S-61 that I could see from an on-line shop are this order: the biggest spare parts for the S-61 are 1) Battery 2) Flex assembly & 3) Display
  • I’d guess that the volume of batteries that are being inadvertently replaced is due to the flex assembly “wear out”- Which is probably the #1 underlying real cause of the failure as the symptoms would manifest themselves as you have described
  • “The battery will not charge, there is no power (not enough coming) through even though the phone is plugged in”
  • If a repair / spare parts store knows this, they wont advertise it as they get you for the battery first and then you’ll come back for the flex assembly?
  • BUY THE FLEX… do we now open a “fix the flex thread”?

The flex assembly is an electro - mechanical component and it will wear out and fail rather than a battery fading away…..

Esta resposta foi útil?

Pontuação 2

27 comentários:

Hello @eureka thanks, for the very thorough and formatted answer!

1. I tried probing 3.7 V directly onto the battery terminals (phone side) with a laboratory power supply but it's the same as running the phone without battery from USB. It vibrates shortly, the screen turns on for less than a second without showing anything yet and the phone immediately turns off. I think it needs to be able to communicate with the battery to turn on.

2. I could try charging the battery outside of the phone with my lab supply but it already has 3.82 V. This should mean it should have enough charge to start up the phone without a cable, right? I'm trying to rule out the flex assembly.

3. I looked at the charging port under magnification and it looks very clean, no bent pins, etc. I suppose any part of the flex assembly could fail at any point but the most likely part simply due to mechanical wear would be the usb port and/or it's connection to the flex cable itself. Do you know any way I could test the flex assembly itself?


Thanks for the kind feedback Fivefold !

I cant source a schematic for the S61 - so this is detective work!

Does your lab power supply have current sensing or if you have access to a meter? - You could try what you did in step 1 and try to see what the current peaks to before the phone switches off (an oscilloscope would be better)

- I dunno if its necessary to probe the 2 battery sense pins into the phone (Btemp and Binterface) to trick it to think its a battery while the power comes from the lab power supply?

2) Indeed, its not so much the voltage but the current also. Macgyver some juice into the battery (sounds like you know what your doing but keep it low ~3.7V ~650mA for 30 min - if you can check the current being drawn, you'll know if its taking a charge)

3) Magnification is great, Ive seen hairline cracks oxidize and form as an insulator and intermetallics form and become conductive.


One might think of the USB port itself as being the source of wear and abuse - which is often true.

However, Flex's are dynamic systems subjected to compressive and tensile loads and vibrations from the moment they're installed. Not to mention environmental (temp/humid).

Traces can also fail at locations of bending in between the polyimide cover layers.

Re; Test the assembly itself.

* If the flex is easily removable, measure from the USB connector pins to the battery connector pins.

* Measure for continuity along the trace AND also to the neighbouring trace for short circuit or a resistance value

* Study the condition of all the other surface mount connectors. Look for signs of oxidation or moisture damage

* You should establish where the bends are on the flex - sometimes holding the flex up to a desk lamp to inspect these areas may highlight a damaged trace.

*Its worth looking around tight corners/ shapes for tears

Wishing you luck!

Btw - I found the flex $6.18


@eureka Thank you so much for the detailed answers! I really appreciate it. This is what I tried by now:

1. I only have access to an old analogue oscilloscope, so one-shot measurements to measure the current are out of the question. The (slow) current meter of the lab supply peaks at about 190 mA when applying 3.7 V directly to the battery terminals, which seems a bit low.

I could try to capture the current over time with the ADC of a microcontroller, although that would be quite a bit of work that I would like to avoid unless the phone itself (not counting battery or flex cable)

2. It took a charge, although I had to go higher than 3.7 V (it was 3.8 V already). It charged at 650 mA when I increased the voltage to about 4.0 V. Let it charge for half an hour, put it back in the phone, no dice. Charged an hour or so (the battery open voltage was at 3.92) and still no dice.


3. The flex assembly is removable without too much work, but it's glued in, so not sure if it would survive taking it out and putting it back in. Unfortunately I lack the tools to meaningfully probe the small flex connectors. I could scratch off the polymide next to the ends to test out the bends, but that leaves the flex connectors and the USB port as a sort of failure. On visual inspection the flex looks very good. I tried opening and closing the flex connector (flex assembly - motherboard) to possibly break up any contact oxidation but that didn't change anything.

The flex you likely found is from a shop that only sells to businesses and with a minimum order of 150 $. Also, I'm situated in Europe. The cheapest flex assembly I found would be about 15 €, a non-original battery would be about 38 €

Currently I'm tending more to try replacing the battery instead of the flex assembly. What do you think?


Exibir mais 22 comentários

Adicionar um comentário

I just replaced the battery on my husband’s Cat s61. When I put it back together I had the issue you described. I took it back apart and connected the battery cable more firmly. I think your issue is a loose battery cable.

Esta resposta foi útil?

Pontuação 1

1 comentário:

I don't have this device anymore, but at least in my case it most likely wasn't a wonky battery connection. I did enough tests so that this could be ruled out with high confidence.

I did notice that the replacement battery I tried had the wrong connector, leading to a loose fit. I suppose that is the problem you had.

Glad to hear it was such an easy fix for you though! Maybe it will help someone else, thank you for mentioning it.


Adicionar um comentário

Adicionar a sua resposta

Fivefold será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 4

Últimos 7 dias: 15

Últimos 30 dias: 81

Duração total: 2,474