Alarm clock doesn´t work, still the display blinks

I lived 6 months abroad, and after I returned home, I realised that I had forgotten to unplug my alarm clock. I found the display working normally, but the digital digit segments were all blinking. (With digit segments I mean the digital 8 which is used to represent all other digits in digital displays.)

Then something interesting happened, I unplugged the device and the display went off. However I can see the digits continuosly blinking even though no current is present and the device does NOT have a battery. It is still blinking even after 10 hours and it occasionally makes a small sound, same sound as if a button is pressed.

How is this phenomenon even possible and is there a way to fix this, or should I give up my hope?

Thanks in advance!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

3 comentários:

Hi @andymueller,

What is the make and model number of the clock?

Have you tried to set the time and an alarm tine to see if the blinking stopped?

It may be that there is a backup capacitor that maintains power to the device when no other power is present.

have you tried holding a set button or similar for 30 seconds or so, to see if this turns the LEDs off when no power is attached?

It's not solar powered as well is it? ;-)


Hello @jayeff, thanks for your answer!

As for the model, it´s rather a cheap no-name alarm clock I found on my local shop, but it did it´s job and I grew fond of it.

I tried setting the time and it worked well for 2-3 minutes. I also noticed that the whole display blinked when a minute passed and the digit changed, which was not the case before. But after that it still went back to blinking everything.

As you said, I tried holding the set button, and it actually worked and I could set the time correctly even though no power is attached, so every button worked as well but I could not turn them off.

And finally no, it isn´t solar powered. It´s just a simple alarm clock.

If it is the case with the capacitor, is there a brute force way to discharge it?



If there is a capacitor then I hoped that it would be discharged completely when the set button was held for ~30 seconds with no power applied (no battery either) to the clock i.e. clock was forced to use more power even though power not applied so it has to come from somewhere. Maybe try for a few minutes perhaps. Very strange that there appears to be power when there is none though.


Adicionar um comentário