Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Peças e ferramentas

Back camera gone after water damage

Got an iPhone 6s with some water damage. Managed to get back everything to working order except for back camera. Since it was missing PP2V85 I removed U3200 which had suffered a short with VccMain.

Unfortunately CAM_EXT_LDO_EN seems to be missing too, although the pin is shiny and undamaged.

Does CAM_EXT_LDO_EN show up only when camera cable is connected or should I just say goodbye to the main camera ?

Respondido! View the answer Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 1
Adicionar um comentário

Kit de ferramentas básico para eletrônica

Kit pequeno. Grandes possibilidades.

Shop Toolkits

Kit de ferramentas
básico para
eletrônica

Shop Toolkits

1 Resposta

Solução escolhida

Hey Arbaman, what do you mean exactly when you say "CAM_EXT_LDO_EN seems to be missing too"? Do you mean the signal or something physical?

I don't remember probing that before but looking at the schematic, it is connected to a UART RTS (Request To Send) pin on the CPU (maybe they ran out of GPIO's!?). Normally, an RTS will go high to initiate a conversation so that's probably what they do here as well; RTS goes high and enables U3200. If you not seeing a signal, you could always pull it high via PP1V8 (or use a DCPS) to see if that enables the camera.

Esta resposta foi útil?

Pontuação 1

Comentários:

@refectio Hey Minho, sorry for my lack of precision but I'm pretty new to iPhone repair attempts..would need some training..lol

Anyway you read my mind, I referred to the missing CAM_EXT_LDO_EN signal which should be enabling U3200 and create the needed 2,85v missing right now.

I will try to run a 1,8v bridge and see if that does the trick..thanks for help for now

por

Adicionar um comentário

Adicionar a sua resposta

arbaman será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 1

Últimos 30 dias: 3

Duração total: 188