Ir para o conteúdo principal

Repair guides and support for smartwatches produced by Fitbit.

628 Perguntas Visualizar todos

Water damage on Fitbit Charge HR

Have a Fitbit charge HR. Jumped in pool with Fitbit on.. Jumped out...

No sign of life:(

Any suggestions??

Have tried drying in rice, recharging and holding button ...

No change..

Anything else I can do?

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 9
6 comentários

I went into the pool also with my Fitbit and it is reacting the same way!!!!! This is a great question that many people ask.


If you end up getting a replacement from fitbit I would be happy to buy your old one.


shoot... happened to me as well.. is there any answer regarding this issue?


Hi @adamaidilpadli.

You could try using the ifixit battery replacement guide to open the watch, disconnect the battery and then clean away as much of the water as possible using Isopropyl Alcohol 90%+ and a soft toothbrush. Be gentle when doing this. When finished allow it to fully dry. Shouldn't take long to dry as is alcohol. Then re-assemble and don't forget to reconnect the battery. Good luck with the repair.

Take pictures before disconnecting /removing anything as an aid to re-assembly in case you forget which way it was etc.

Fitbit Charge HR Battery Replacement


Same problem here. Second Fitbit this has happened to.


Exibir mais 1 comentário

Adicionar um comentário

2 respostas

Pergunta mais útil

I was able to take mine apart, cleaned, and back together working. Of coarse I tried this after fitbit sent me a replacement under warranty. It was not the easiest thing, and didn't go back together as clean as I wished but it works. If you would like to donate it to me i would be happy to pay shipping plus a little extra, please email me, SethMcMichael at gmail.

EDIT: here is a link with a few pics of how to take it appart. it goes back together the same way, just be careful with the button part.

Esta resposta foi útil?

Pontuação 3

5 comentários:

Hi Seth! Thank you for posting a solution that worked for you! I tried everything you said and it turned back on with an "update bar" half filled?? I can't get it past this. Did this happen to you? Any suggestions?

Thank you!


Sorry didn't happen to me. Did you try plugging it in and holding the power button? That will soft reset the device.


Yes I did but it didn't do anything. It is just froze on that bar half way. Thank you for all your help. It was worth a try!


Kathy, were you able to fix your Fitbit? I'm having the same issues....thanks


No I wasn't :( Had to buy a new one.


Adicionar um comentário

Sorry, i did not take any pictures while taking it apart. But, let me see if i can remember.

First take out the 4 screws that you can see. Next i believe i used a small flat head screw driver and pried around the plastic part where the button is. Now when you do this it will probably brake the plastic clips but thats ok, i used a dab of super glue to keep them together after testing and putting back together. After you get in you are on your own, i forgot at this point what i did exactly.

Just use a toothbrush and alcohol and try and clean the corrosion from the water the best you can. If you get stuck send me a pic and i can see if it helps me remember what i did.

Good luck!

Esta resposta foi útil?

Pontuação 1

2 comentários:

Thanks a lot for explanation. I'll try to fix it and take pics of the process to help others.


Hi Seth McMichael. Could you please share your experience on how to disassemble the fitbit charge HR. Do you have any picture of the process?


Adicionar um comentário

Adicionar a sua resposta

Kevin Beebe será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 5

Duração total: 18,425