My Spartus alarm clock is displaying weird symbols.


I've had a Spartus Digital Alarm Clock for a while, but it never worked. Whenever I plug it in, it just shows this:

Block Image

But when I put in a 9-volt battery, it works, but runs 5 minutes fast.

Here's some things I've tried:

  • Opening up the unit to see if anything was wrong
  • Seeing if any contact points were not connecting correctly ( i ended up almost shorting the board because i used the metal end)
  • Checking for frayed wires
  • None of them resulted in my clock working. How can I fix this?
Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

5 comentários:

Can you try resetting the device ?


the model number is 1297


I have a Spartus alarm clock that uses a 9 volt battery for backup but it gains minutes and minutes over a 24 hour period it may gain two hours, however, if I remove the battery it keeps perfect time with another digital clock I have sitting next to it. Once the display began flashing and I tried to reset the time but that didn't stop the flashing, so I inserted the battery and the display stopped flashing and then after a few minutes I removed the battery and it continued to hold a continuous display. The time is still being kept accurately and hasn't started flashing again. So something with the battery backup circuit is causing the time circuit to speed up and I'm wondering what it might be? A resistor that has gained or lost resistance causing a lower or higher voltage in the circuit or a capacitor that is not holding its charge voltage?


@edburns68659 I don't know what you mean by this. I am an amateur when it comes to repairs, and I just want it to work again. I read a similar post to this but with a different manufacturer and model, and tried their methods. It still does not work. Please help.


Adicionar um comentário