Ir para o conteúdo principal

Released on October 23, 2012. Core i5 or Core i7 Processor. Apple Fusion Drive.

209 Perguntas Visualizar todos

Mac mini late 2012 won’t power on, white led stays off

I have a Mac mini that won’t power on, when I press the power button I don’t get anything, even the white led stays off. I have taken it apart and tested the power supply with a multimeter and found that it outputs the correct voltage, so guessing the power supply is not the issue - and it is more likely the logic board. Is there anything I could check to get more of an idea why it won’t power on? I suspect a full logic board replacement would fix everything, but that repair wouldn’t really be worth it, as the logic board on eBay is around 80% of the price of a whole new Mac mini. Also this is an old computer by now so not really worth spending that money on. Are there any components that commonly break on the logic board that I could check? Could faulty RAM/ other components cause this?

Thanks in advance :)

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

2 comentários:

@liamriley39469 I would start by unplugging any hard drives or SSDs and only leaving 1 stick of RAM in. If you have known good RAM of the same type, you should swap the RAM in the machine for the new RAM.


Thanks for that, just tried with no ssd and only one ddr3 stick installed - no luck:( I’m pretty sure that it is the right type as this was working for years beforehand, and it was the recommended upgrade kit for this Mac mini on the crucial website. Also ran it through memtest86 on another system and it passed fine.


Adicionar um comentário

1 resposta

How have you tested the power supply? It may measure 12V when removed from the Mac, but it could have issues operating under load. If you can, probe the power supply outputs with it connected to the logic board, and see if anything happens when you attempt to turn on the computer.

Another thing to check is if the fans spin at all, a "quarter spin" behavior when the power button is pressed can be indicative of issues with the logic board that would require professional repair.

Finally, are you sure there isn't an issue with the power button itself? If there's absolutely no activity when the button is pressed, maybe it's defective. You may be able to trick the mini into powering on by shorting out the power button's pins where it connects to the logic board, but you must be careful not to short anything else out inadvertently.

Esta resposta foi útil?

Pontuação 0

5 comentários:

Just tried all of those - thanks so much for thinking of them! Results

* Power supply still outputs 11.88 volts when the logic board is connected and power button pressed

* Can’t see fan movement or any other indication of computer trying to start up when power button pressed

* Power button seems fine, looks like a normally closed button and multimeter continuity test beeps when button pressed down

It’s not looking promising :(

Do you think there’s anything on the logic board that I could check?


A full removal and visual inspection of the logic board may be in order, I'd look for anything that looks visibly burnt or broken, and also look for lose components rattling around the case. I don't have a good lead on this, but if you could find a diagram of different voltage test points on the logic board, you could probe them individually to make sure all power regulation circuits are good. The logic board on these machines takes in 12V and creates a bunch of other voltages necessary for system operation.


Thanks so much for your help with this! After a bit of looking, I couldn't find anything about voltage test points on the logic board. Also double checked the PRAM battery voltage as some videos suggested that this could prevent the start up (was not an issue in my case, battery voltage at 2.9v). I started randomly probing different points on the board with the power supply attached and found one component of interest, marked "39 C34" (couldn't find anything when googling that and not actually sure what type of component this is - do you have any idea?). Picture:

At point 1: I measured 11.88 volts, so the base voltage that the power supply outputs, but at point 2 the voltage dropped to 0. Also, a continuity test showed 0 resistance between point 2 and ground. Could this component be the issue, or could it be another component nearby? Could you suggest any further testing? Thanks so much for your help!


That components looks to be an overvoltage protection diode (also sometimes called a Zener diode). You can google around to get a better idea of how these circuits work. They are generally put in place to protect the logic board from a bad power supply. The behavior you observed sounds perfectly normal to me, and I wouldn't consider it an issue. There should be ~12V across the component and one side should be connected to ground (0V).


Ah right that makes sense, thanks for explaining! I've managed to get a board schematic, but unfortunately I have no idea where to even start with troubleshooting the board - never attempted board repair of any kind before! Do you have any tips?


Adicionar um comentário

Adicionar a sua resposta

Liam Riley será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 17

Duração total: 96