Ir para o conteúdo principal

The HyperX QuadCast S is a gaming USB microphone with RGB lights. It was released on September 28, 2020, by HyperX. It may be customized through the INGENUITY Software. It has a Tap-to-Mute Sensor with an LED indicator.

1 Perguntas Visualizar todos

Quadcast S not showing up in Device Manager (Win 11)

I have had issues with my ~2 year old Quadcast S for a bit now, nothing that prevented it for working though. For the past week the microphone had an error show up when plugged in, nothing I couldn't fix, I uninstalled the "unrecognized device" from Device Manager, reinstalled USB Composite Devices and it always started working. Today, the Quadcast S isn't even showing up in Device Manager.
Things I've tried:

  • Reinstalling Everything USB Related in the Device Manager (showing hidden devices)
  • Reinstalling Everything Audio Related in the Device Manager
  • Every other USB Port
  • Testing the original cable on another device (can charge and transmit data)
  • Using a USB-C to USB-C cable
  • Heating it up (as suggested on Reddit by another User with the same issue)
  • Changing Power Settings

Other Notes:

  • The Device isn't showing up in Device Manager
  • The RGB Lights aren't on
  • There is no connection sound made by Windows when plugged in
  • There is no pop-up by Windows when plugged in
  • I use NVIDIA Broadcast
  • All the drivers are up to date

It's as if the microphone doesn't exist. Help is appreciated, thanks!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
Adicionar um comentário

2 respostas

Pergunta mais útil

Hi @andjibilic,

Have you tried connecting the mic to another computer to see if it is being detected OK, you didn't say?

If it is not being detected by other computers as well, try connecting an Ohmmeter across the USB cable plug (or the mic's USB-C port) D+ and D- data pins, and also the VBUS and GND when testing towards the mic to see if it detects either or both the USB controller or the power circuit on the mic's motherboard

You have checked that the USB-C cable is OK so it may be a loose USB port connection in the mic or a problem on the motherboard in the mic.

Here's a link showing the USB-C pinout that may help.

If it is being detected OK when connected to other computers what is the make and model number of your computer?

Esta resposta foi útil?

Pontuação 1

2 comentários:

Hey @jayeff

I have tried plugging the Mic into a PS4, and nothing happened even though it should be compatible. Sadly I don't have another PC or Laptop available. I'll try an Ohmmeter later if I can get my hands on one.

por

@andjibilic

Perhaps if you have a USB-C type phone charger you could try that.

At least to see if the mic shows it has power

por

Adicionar um comentário

I have the same issue. I tried everything and nothing happens.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Andjelko Bilic será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 5

Últimos 7 dias: 29

Últimos 30 dias: 149

Duração total: 975