Ir para o conteúdo principal

Line of business laptops originally sold by IBM and then purchased by Lenovo in 2005. Older models (Pre-XX50) have a WiFi whitelist, so wireless card replacement is not as easy as buying a bulk generic card online.

577 Perguntas Visualizar todos

it appears completely dead.

Hi, I hope you are still here. I have a Lenovo Thinkpad E531 that I use rarely. I recently tried to use it for the first time in about 3 months, and it appears completely dead.

The only sign of life is that when I plug in the (original) Lenovo power adapter to the laprop, the i in Thinkpad flashes red 3 times. That is it. Power button does not light up, nothing.

I can believe the battery is completely dead and un-chargeable, and it is now removed.

I also removed the hard drive, DVD drive, and RAM with no change in the problem.

I tried measuring the power plug with my voltmeter. Of course the 120VAC plug is plugged in to a live outlet. Then measuring the plug that goes into the laptop, from the rectangular grounded outer shell to the inner central pin, there is zero voltage.

Should it be reading 20V (live) even when not plugged into the laptop? If yes, that is at least one of my problems. Or is it smart so it only goes to high voltage when plugged into the laptop?

Thanks for any ideas or help.

Update (03/23/2022)

Answering partly my own questions, in case someone else has a similar problem ...

I took the whole laptop apart. Confirmed 20V measured internally at the power plug, so the power supply is smart enough to not make the central pin live unless it is plugged in.

I also measured my battery. 10.8V printed on the battery, measured at 11.7V, go that is not the problem either.

Checked the switch and where it connects to the mother board. The power button is connected to a 4-wire ribbon. When the button is pressed, the two middle wires are momentarily connected. I'll assume the outer wires are to light the button, but did not test. Also tried shorting the two wires on the motherboard that the power button would connect when pressed - no change.

That was enough for me. Checked the easy things - power, battery, power switch, and will basically give up now ... except, as I have learned with other laptops over the years, I will try again once in a while to see if it fixes itself. Yes, it does happen, LOL.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
Adicionar um comentário

1 resposta

Pergunta mais útil


A 3 blink Thinkpad logo light indicates that the laptop is initially connected to AC power, so at least it knows that power is available, which you already proved anyway.

Try a power refresh and check if that works just in case the BIOS got corrupted due to the flat battery and possibly a flat RTC battery

Since you have it open it will be easier and also that you have removed the main battery as well.

Make sure that you have re-assembled the laptop in that the memory is inserted and the power button board is reconnected. The HDD and ODD initially won't matter.

Do not insert the main battery and then remove the RTC battery and then press and hold the Power On button for a full 30 seconds and then release it. Here's the hardware maintenance manual for the laptop. Go to p.73 to view the steps to remove the backup battery (aka RTC battery or CMOS battery).

Also with the RTC battery disconnected, measure its voltage. If it is <2.5V DC replace it. The replacement part # is 04W4118 (or compatible equivalents are 01HY789 & 01HY790) Search online using the part number only to find suppliers that suit you.

Reconnect the RTC battery and the charger and try turning it on. Hopefully it will POST (but not boot if the HDD is still out) and give a message about no OS etc. You should be able to get into BIOS though (press F1 when the Lenovo logo is on the screen)

If it does start you might get a message about incorrect date and time. This is normal as the BIOS has been reset to default. Once the D&T have been corrected the message will not appear again the next time the laptop is started.

If still no good it is a motherboard problem. What is the model number of the motherboard as printed on the board itself?

Esta resposta foi útil?

Pontuação 2

3 comentários:

Thanks for that detailed response. Hopefully it will help someone else some day.

Unfortunately, prior to seeing your response, I had already put the whole thing back together. And ended up giving it away.

I had also previously done the standard power button hold down, etc. to allow any static charge to dissipate, with no change.

I did not test the 2032 BIOS battery at all. In previous laptops where that died, I'd still at least get a partial BIOS attempted boot, screen lighting up, etc. In my case there was never anything at all ever, other than the i-dot in Thinkpad flashing red 3 times after connecting the power supply.


I have almost the same problem, only that my laptop turns on the screen but there is no lenovo logo. I tried everything you said and now it makes 2 beeps and the screen is on but without the lenovo logo, what can it be?

por Two beeps is usually a general POST or RAM verification issue. Your display is most likely relying on the Ram so , no display (just the backlight turning on making you think it is displaying something.. Remove the Ram and see if you get the same error or if it has changed.


Adicionar um comentário

Adicionar a sua resposta

Al Einstein será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 16

Últimos 30 dias: 91

Duração total: 2,105