Laptop having trouble connecting to TP-Link range extender

Hi all,

I am having trouble with my TP-link range extender. I use it in access point mode and my laptop has a lot of trouble connecting to it wirelessly. The odd thing is that my phone connects to it without a hitch.

Sometimes my laptop connects to it in one go, sometimes it needs 20 attempts until it finally connects. I am wondering what I can do about it.

Things I have tried:

Different OS, changing the channels of our router and updating wireless drivers. My laptop uses a killer wireless card.

Hope anyone can help! Cheers

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0

Comentários:

Hi @nixni,

Does the laptop connect OK every time with the WiFi router?

Does the laptop connect OK when placed as close as possible i.e. <20cm, to the range extender?

What is the model number of the range extender?

What is the make and model number of the laptop?

por

Hi Jayeff,

The laptop connects just fine when connecting to the main router. When connecting to the wifi extender I am sitting really close to it so range shouldn't be an issue.

The model and make is: TP-Link RE200 AC750 and the laptop is a MSI GS75 Stealth 10SE

por

@nixni

Have you checked in the extender's system log to see if there is anything in there that might tell you what is happening?

I know that you said that your phone works OK with the extender but just to eliminate a signal reception problem in the laptop, download, install and run this WiFi sniffer program to check the strength of the signal from the extender.

When using the program remember that the the strength is in -ve dBm so the higher the number, the lower the actual strength of the signal.

You could also try connecting in safe mode and check if it works OK

Here's how:

Press Windows key + R key to open the Run dialog

Type msconfig then click OK

Select the Boot tab and select the Safe Boot and the Network boxes then Apply and Restart

When the computer reaches the Lock Screen click on the Network icon and select the wireless network, then enter the password.

Then sign into the Safe mode desktop

por

Hi @jayeff I have tried all the troubleshooting steps but unfortunately to no result. It takes just as long in safemode to connect to it as it does normally. Using the program the signal is really strong. Is there anything else I can try? Cheers!

por

@nixni

What frequency band are you using between the extender and the laptop, 2.4GHz or 5GHz? Just wondering if the problem is related to that.

Also is the latest firmware installed in the extender?

por

Mostrar mais 3 comentários

Adicionar um comentário