Ir para o conteúdo principal

The Kia Rio is a subcompact car produced by the South Korean manufacturer Kia since August 2000 and now in its fourth generation.

36 Perguntas Visualizar todos

Led tail stop lights outer and LH inter do not work. Need technical

Car is 2013 KIA REO SX Sedan 4 door, with LED taillights and stop lights.

 The outside assemblies have turn signal incandesce lights, taillight and stop function led lights. The inside assemblies have backup incandesce lights, taillight and stop function led lights

Problem.

The stop light LED’s do not work correctly. There are 5 rear light assemblies on this car. 1 each on the rear quarter panels (identified as outside) and 1 each on the trunk ((identified as inside) and 1 in the high center mounted over the trunk (stop only). The stop light function does not work on the 2 outside assemblies LED’s and the left hand inside assembly LED’s. The taillights LED’s all work.

The cost of new LED assemblies is about $225.00 each.

I used a volt-ohm meter to check for proper voltage and ground connections.

GROUND CHECK- I disconnected the wire connectors of the car from all the assemblies.

I verified the ground connection by; (a) Black lead of the car wire harness connected to the ohm meter and ohm meter connected to the chassis and (b) the black lead of the car wire harness connected to the ohm meter and the ohm meter connected to the battery ground post. In both cases the resistance was 0 ohms.

VOLTAGE CHECK – I connected the voltmeter neg. led to chassis and the positive lead of the voltmeter to the red/or lead of the car harness, one connector at a time and had a helper apply the brakes, ignition off. All 4 of the car connections had 12.8 volts dc. I then connected the positive lead of the voltmeter to the green lead of the car harness, one connector at a time, and turned on the taillights, ignition off. I had 12.7 volts dc. I then repeated these steps with the car running with the same results except the voltage was 13.8 volts dc. This verified proper voltage to the light assemblies.

Not wanting to spend the money for a new assembly I found a used one left hand inside assembly and ordered it. When it arrived, I installed it and applied the brakes, the stop light worked on the LH inside assembly and the RH inside assembly (this was working before), good I thought. I then turned on the taillights and they worked, good I thought. Then with the taillights on I applied the brakes, no brake lights, now what?

During all this I found out that with the taillights not on and when the brakes are applied that the taillights of each assembly come on. Remember that the RH inside assembly is working, I am not sure if the taillights are supposed to come with the brake lights if the taillights are not on to start with.

I decided to rig up a test light using a 1157 incandescent bulb and the connector from the light assembly that I removed. With this I verified that the stop light and taillight function work and the taillights do not receive voltage from the car harness when the brakes are applied. I assume that on the driver board for the LED lights there is a trace causing the taillights to come on if the taillights are not already on. I made another test assembly for the removed LH light assembly. I connected a ground lead to the black lead and a positive lead from the battery to the green lead of the assembly. The taillights worked. I then connected the positive lead from the battery to the red/or lead of the assembly, the stop light LED did not light work, but the taillights did.

I reviewed the rear lamp circuit from ShopKey Pro. I noted that there a many common connections. Wire lead 10 (red/or) that feeds the left rear outside stop light and wire lead 11 (red/or) that feeds the right rear outside stop light have a common point at the connector designated EF11. This also connects to high mounted stop light and the inside stop lights.

Now back to the EF11 connector, this leads to a 9-wire assembly lead blue connection point 5 and to a 10-wire assembly lead blue point 6.

Blue point 6 leads back to the ESC module The ESC module has an input from the brake switch (pin 9 blue), stop lamp signal (pin 23 green) from the stop lamp relay (3 green), and the HAC relay (pin 8 brown)

Blue point 5 leads back to the HAC relay (pin 8 blue).

 

********This is what I know.

A. the turn signal lights work.

B. the backup lights work.

C. the RH inside assemble works.

D. the taillights work.

E. The stop light led’s on the outside and the LH inside do NOT work.

F. The stop light over the trunk works’

 

This is what I do NOT know.

A.  What could the cause of the LED driver on 3 of 4 (plus the one purchased) assemblies to go bad.

B.  Are the taillight suppose to come on when the brakes are applied, and the taillights are not already on?

C. Can I use the Incandescent light assemblies on the car? I know that the 2012 through 2017 assemblies are the same but does the wire connector on the assembly match up to the wire connector on the car side. If they do not, I can splice in the correct connector from the old assemblies.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
4 comentários

The Same thing going on with my 2012 Kia Rio sx sedan, except I have break lights in the outer right and inside left, which makes absolutely no sense at all. I didn’t monkey with it to much but I switched the lights around and the one that was working on the left didn’t work when placed on the right, which tells me wire issue but it makes no sense from where. I thought about switching out the led for the Incandescent lights then I would have to change the wire harness and I’m not sure if the wire harness would connect to the existing wires, no one will let me try before I buy and return policy is kinda shady from savage yard and I’m not gonna pay full price for the lights to just break again.

por

Hi John, Some great troubleshooting on your part. I have pretty much the same issue, but in my troubleshooting it appeared to be the light assembly that was at fault. Actually if I wiggled the connector I could see the light come on (very dimly though). Yes, my though too was to go to the incandescent style - do we now know if this will work. Much cheaper. Have you had any alternator issues on this car?

por

I found that the wire car wire harness is the same weather the car has LED's or incandescent units. I took one of each (1 inter and 1 outer unit) to the junk yard and verified that the wire harness are the same. I purchased all four units incandescent unit. They are working correctly since that repair, have no other problems.

por

Thanks - I was thinking this as the online stores that sell both say they can work, but sometimes those AI bots are wrong. Thanks for confirming. So, sound like in the end - it was the light assembly?

por

Adicionar um comentário

1 resposta

Pergunta mais útil

Hi @j_f_l_ ,

Got a bit lost with all that you’ve tried so here’s the 2012 Kia Rio EWD – Stop Lamps 2/Tail, Parking & License Lamps wiring diagram from the Kia Rio (UB) 2011-2017 Service Repair Manual + Wiring Diagrams that may help you to work out what’s going on.

It seems everything emanates from the ESC module so the problem may be there or in the wiring to the lamps. Easy to say I know but you may have to trace out the wires. At least all the connection points are shown.

Hopefully this is of some help.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

Adicionar a sua resposta

John será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 9

Últimos 30 dias: 21

Duração total: 1,107