Ir para o conteúdo principal

The Asus Republic of Gamers G20 is a small-form-factor gaming PC with enthusiast-level components and good performance. Released in 2014.

17 Perguntas Visualizar todos

Asus bios no CSM option please help

Block Image

Hello I was just watching YouTube last night and my pc froze I restarted it and it never comes off the bios screen everytime I restart it it opens the bios screen I've looked at many tutorials and all of them have extra options in the boot settings I only appear to have 2 options and none of them are CSM or Legacy (what most of the videos told to change ) is there any help I've attached a photo of what I've got , my bios version is 307 Asus

Update (07/14/2021)

Block Image

this is my bios

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
2 comentários

Same problem here ,no can options,no boot priority listed ,no bootable device located


What is the exact model number?


Adicionar um comentário

1 resposta

Pergunta mais útil


There is no image with your question.

Here’s how to add images on Ifixit Adicionar imagens a uma pergunta já existente.
Don’t know the PC but if you have:

Legacy BIOS go to Save and Exit > Restore defaults > Yes. Then go to Boot > Boot Option #1 and make sure that the HDD is selected. Then go back to Save and Exit > Save Changes and Exit > Yes.

You will need to use the arrow keys on the keyboard to navigate through the menus and the Enter key to select the option

I think that it is the same for UEFI BIOS except that you should be able to use a mouse to navigate.

Update (07/14/2021)


Try a power refresh and check if that resolves the problem.

Turn off the PC and disconnect the power cord from the PSU.

Press and hold the PC’s power On button for a full 30 seconds and then release it to hopefully restore the BIOS.

Reconnect the power to the PC and then see what happens.

If still no good then you may have to turn off the PC and disconnect the power cord from the PSU and also open the desktop and disconnect the cmos battery from the motherboard and then press the Power on button for a full 30 seconds. Then replace the cmos battery, reassemble the desktop, reconnect the power and then turn on and check etc.

Here’s a video that may help with opening the desktop as this video which shows the cmos battery isn’t that good at showing this.

Here’s a composite image taken from the 2nd video showing the location of the cmos battery and where it is plugged into the motherboard.

Block Image

(click on image to enlarge for better viewing)

If still no good then you may have to contact Asus as I don’t know how to reflash the BIOS if it is corrupted that much

Esta resposta foi útil?

Pontuação 1

7 comentários:

Hi Thank you for replying ! But unfortunately that I can't do what you told me I only have 2 options I have attached the image


@jayeff not sure how to use this but I'll @ you incase you don't see my reply



So you can't get to the Save and Exit menu then as I described?


@jayeff No my bios keeps opening every time I restart and I can't get on the pc and there is no options for CSM or Legacy setting or even the thing you told me to do I don't have option 1 anything like that


I've got like only 2 options in the boot tab and the videos I watched to sort it had alot more options


Exibir mais 2 comentários

Adicionar um comentário

Adicionar a sua resposta

majkls3 será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 12

Últimos 30 dias: 90

Duração total: 2,979