Pular para o conteúdo principal

Model M5884 / 400 or 500 MHz G4 processor

27 Perguntas Ver todas

No power

Dear all,

my beloved PowerBook Titanium does not want to power up. Battery is ok as well as power supply. Any idea?

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 3

Comentários:

Have the same problem. Tried resetting and still nothing.

por

Adicionar um comentário

3 Soluções

Resposta Mais Útil

Try looking here: http://support.apple.com/kb/HT1431#faq8

Resetting the PMU might do the trick. I know the ol' Titanium is sweet, but it also might be time to look at a newer model.

Esta resposta foi útil?

Pontuação 2
Adicionar um comentário

It could be your DC-in board. The best way to test it would be to slide in another battery that has a charge to it... if the computer turns on, it is most likely your DC-in board. You can purchase one here if you are interested:

G4 Titanium DVI DC-In Board

And you can look at the repair guide here:

PowerBook G4 Titanium DVI DC-In Board Replacement

Esta resposta foi útil?

Pontuação 1

Comentários:

Beware Tyler's solution does not apply to the Mercury Model. The Mercury doesn't have a separate DC-in board.

por

Adicionar um comentário

Try taking out your PRAM battery, shown in the remove PMU guide (it's the big thing marked 616-0114-A)

Disconnect the tri color lead from that to the PMU, start up the PowerBook (it should now work), then reconnect that cable and hopefully you should be left with a functioning PowerBook !

Esta resposta foi útil?

Pontuação 1

Comentários:

So, disassemble to step 16, disconnect the tri color lead, reassemble, turn on computer. Disassemble to step 16, reconnect tricolor lead, then reassemble? Is that correct? Why would this work?

por

Adicionar um comentário

Adicionar a sua resposta

Emerenziano será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 1

Últimos 30 dias: 8

Todo: 6,914