Ir para o conteúdo principal

Philips Alarm Clock radio for iPod/iPhone AJ6200DB/98.

1 Perguntas Visualizar todos

Why is Philips Clock Radio showing - - : - -

My Philips Clock Radio AJ6200D/98 was working fine. I unplugged it and when I plug it back in, it is now showing - - : - - for the time. None of the buttons are responsive. I’ve turned it off and on, hold the source for 3 seconds, read the manual but nothing. Any ideas?

Block Image

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

1 resposta

Solução escolhida

Hi @munchine ,

Has the clock/radio got backup batteries installed at all?

Here’s a link that shows where they’re located.

If so, disconnect the power from the device then remove the batteries.

After they’ve been removed, turn on the device for about 10 seconds and then turn it off again. This is just to dissipate any residual charge left in the device that may be holding any corrupted settings that may be preventing a normal operation.

Then reconnect the power to the device and see if it is now working etc. You can leave the batteries out at this stage as they are only there to maintain the settings in the event of a power failure. Also check if they may need replacing by measuring their voltage with a digital multimeter (if you have one) or if you think that they’ve been there for a long time.

Esta resposta foi útil?

Pontuação 0

2 comentários:

I didn't have the battery in but after reading your comments, I left it disconnected over night and it worked the following morning. Thanks.

por

@munchine

Thanks for the feedback.

Maybe I was too optimistic about it only taking 10 seconds to dissipate and reset and should have specified a bit longer, perhaps 5 minutes turned on without power.

Regardless you solved it in the end.

Cheers

por

Adicionar um comentário

Adicionar a sua resposta

Mach será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 8

Últimos 30 dias: 17

Duração total: 746