Ir para o conteúdo principal

The Range Rover Sport was prefigured by the Range Stormer concept car, introduced at the 2004 North American International Auto Show.

6 Perguntas Visualizar todos

My nav screen and radio say low power while driving

What is causing my navigation screen and radio to both say low power while driving and then shut off until I disconnect the battery then they will turn back on again but only for a few minutes I replaced the battery any alternator checked out fuses. anybody please help. Its not a low power problem my battery and alternator are new. Thanks

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário

2 respostas

Hi,

Don’t know but you may have to check the voltage level being supplied to the unit itself to determine whether it is in the unit or in the power supply path to the unit.

No doubt this will be difficult if it only occurs whilst driving. It sounds like a loose (high resistance?) connection that is being affected more by the movement of the vehicle

Here’s the Range Rover Sport L320 2005-2008 Repair Manual +Wiring Diagrams

Scroll down and select the Electrical Wiring Diagrams link suitable to your particular model. Once the file has opened you will have to search through it and find the power supply wiring path for the radio/nav unit. At least once you know which harness connectors the power goes through for the unit you may be able to inspect them first and then somehow contrive to insert the leads of a Voltmeter into the appropriate connector and check what the voltage is at that point when driving. If it doesn’t alter then move on to the next connector etc, until you’re at the radio/nav unit

Get back here if you need more help. Supplying which electrical wiring diagram is the correct one to use will also help ;-)

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Was the car told it had a new battery? Might be worth trying that if you know anyone that has a machine capable.

It would be worth confirming that the alternator is outputting correct voltage when running and stays at the correct voltage when consumers are turned on.

If those things check out then it would be worth checking the Battery Monitoring Support wire which goes from the battery terminal to the Body Control Module. Last one I did only had one wire going to the BCM and I was able to run a temporary overlay to confirm it was the fault, could try that before carrying out a permanent repair if that is the cause.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

D. Digital99 será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 1

Últimos 30 dias: 11

Duração total: 215