Ir para o conteúdo principal

The Lenovo Yoga 730-13IKB is a folding 2-in-1 laptop produced by Lenovo. It has a 13-inch touch screen and is designed for power users. The laptop can be identified by its model number, which begins with “81CT”.

4 Perguntas Visualizar todos

Touch Screen not working

Hi, my screen is not cracked or anything like that. The issue is that the touch commands are not working at all when i tap on it. Any solutions?

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário

2 respostas

Hi @carlos57 ,

Check the status of the Touchscreen in Device Manager to see if it is disabled or if it has driver or other problems.

To get to Device Manager, right click on the Windows Start button (left side of the Taskbar) and click on the Device Manager link.

When in Device Manager, scroll down to Human Interface Devices and click on the > symbol to the left, to expand the HID list.

If the HID Compliant Touchscreen entry has a red cross next to it, right click on the entry and click on enable and then check if the Touchscreen works OK.

If the HID Compliant Touchscreen entry has a yellow exclamation mark next to it right click on the entry and click on update drivers and follow the prompts. You need to be online for this to work. Once the drivers have been updated check if the touchscreen works OK. If you get a message that the drivers are already up to date then read on.

If the HID Compliant Touchscreen entry has no red crosses or yellow exclamation marks next to it and the drivers are up to date, right click on the entry and select Properties. Check the status of the device in the Device Status box in the General tab to see if it says “This device is working properly”. If it does then go back and disable the Touchscreen and then re-enable it and check if this resolves the problem.

At the Device Manager HID Touchscreen entry right click and click on disable. A prompt window will appear saying Disabling this device will cause it to stop functioning. Do you really want to disable it. Click Yes.

Then go back and enable it again by right click on the HID Touchscreen entry and click enable and check if it now works OK

Update (07/28/2020)

Hi @carlos57 ,

Did you try uninstalling the touchscreen in Device Manager and then restarting the laptop and let Windows “find and reinstall it” again, you didn’t say?

I don’t have a touchscreen laptop, so I’m not sure if touchscreens work in safe mode or not, but try starting the laptop in safe mode and check if it works OK.

If it still doesn’t work then here’s the service manual for the laptop.

Go to p.46 to view the necessary pre-requisite steps and then the procedure to remove / replace the LCD panel. I can’t find the pinout for the EDP cable but it may be worthwhile to check that the cable is securely connected at both ends, in case the touchscreen wires in the cable are at one end of the plug and it is not inserted fully into the connector etc.

If it appears to be OK then all you can try is to replace the LCD module. On p.59 Item #2 you’ll find the part numbers for the two LCD modules that are available for the laptop. The touchscreen and LCD screen are one complete module and not two separately replaceable parts. You may find the part number printed on the back of the LCD module itself, if you wish to verify that you have the correct part number.

If you search online using the part number only, appropriate to your particular laptop, you’ll get results for suppliers of the part

Esta resposta foi útil?

Pontuação 0

Comentários:

Hi, I already tried this and it didn’t work. Im starting to think that it’s a hardware problem.

por

Is your problem solved? I have the same issue

por

Adicionar um comentário

None of the mentioned things solved my problem for Yoga 260, the touchscreen was working and suddenly failed as I flipped it back to normal laptop mode. I could see an "Unknown Device" (in Device Manager). When I try to update it via Device Manager, it (expectedly) fails however it comes up with it's name, which was Wacom (something). I installed Driver Easy (not free), it failed to install the Wacom driver for me, however it did mention the version number. I looked for it on the internet and got a similar version number, this fixed my issue. You can find the driver here:

https://us.wacom.com/en/feeldriver/index...

Or direct link:

https://us.wacom.com/en/feeldriver/get.p...

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

ortizcarlos1899@gmail.com será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 9

Últimos 7 dias: 78

Últimos 30 dias: 238

Duração total: 4,374