Ir para o conteúdo principal

Energy distribution node, utilized by the Protoss to tap into the psionic power matrix in order to power their structures. Also supports USB charging.

1 Perguntas Visualizar todos

Devise not charging when turn on.

My pylon still takes in power, but I have to do some crazy things like turning it upside-down and/or pulling the cord for it to on the rare occasion to charge what I plug into the USB's. What can I do to fix my Protoss Pylon so I can use it without doing crazy things to get it to work?

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 1
Adicionar um comentário

4 respostas

Solução escolhida

Robert Kyser  could be an issue with the power port or the wiring. Time to take it apart and investigate further. Use this teardown to get a better idea. Of course make sure that your power supply fits properly etc.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

it is almost certainly a loose solder joint. check the back (blue) side of your PCB and slightly wiggle your power connector while observing the solder joints on the back of the board for movement. when you identify which one has come loose, simply reflow it with a soldering iron providing a solid connection. youtube this process, it is very easy.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

I read the teardown after I took it apart, which was before I posted the question. I found that movement affected whether or not the device worked as intended, but couldn't replicate the conditions needed for it to work properly. The wires looked good, but the power supply connection point was slightly loose and was part of the movement to work conditions; but as I can't figure out what else is needed to keep it running properly, I'm at a loss as to what's actually going on inside of the device. With all these factors to consider; is there anything else that I can do to fix it, or am I better off getting it replaced?

Esta resposta foi útil?

Pontuação 0

1 dos comentários:

it is almost certainly a loose solder joint. check the back (blue) side of your PCB and slightly wiggle your power connector while observing the solder joints on the back of the board for movement. when you identify which one has come loose, simply reflow it with a soldering iron providing a solid connection. youtube this process, it is very easy.

por

Adicionar um comentário

Had the same issue with it needing to be wiggled in order to turn on. Reflowed the DC jack as eadie.martin said and everything is good as new. First time soldering and it was super straight forward.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Robert Kyser será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 2

Duração total: 163