Skip to main content

The fourth-generation Surface Pro tablet, released October 26th, 2015.

106 Perguntas Visualizar todos

Battery Not Present After Battery Replacement

I just replaced the battery in my SP4 using ifixit’s excellent guide. I have not adhered the screen to the base yet because I wanted to test first. Attached AC power and turned it on. Everything works except it is reporting “Battery not present” and dies as soon as I disconnect AC. Device manager also has nothing under Batteries. Any ideas? Thanks!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

Kits de reparo de android

A new screen or battery is one kit away.

Comprar agora

Kits de reparo de android

A new screen or battery is one kit away.

Comprar agora

1 Resposta

I recommend confirming the device model for compatibility then checking the connection to the motherboard to make sure that it is secure. Is this by chance an iFixit replacement battery? If so, please feel free to contact our customer support for further assistance.

Was this answer helpful?

Score 0

Comentários:

Unfortunately, iFixit doesn’t sell the SP4 battery (at least I couldn’t find it just now). But here is the really stupid part. After I submitted my question, I went back and checked and found that I had installed the battery upside-down. This is still at the point that the SP4 would power up, but of course it couldn’t find the battery. I removed the battery and reinstalled it correctly and now it won’t power-on. I then pulled the battery completely out and tried again without luck. I’m going to back in, reinstall the battery, double check everything and see what happens.

by

The battery connector has like a small plastic piece that has a grid of metal spring pins that goes on top then the battery connector goes above that with the screw to hold it all down.

Have you confirmed that plastic piece is there? That part is really easy to lose if not careful.

This was on the SP3 not sure if the 4 has the same thing.

by

I had read somewhere about that, but it was just a single comment on another board, and since it was not part of the iFixit replacement tutorial, I ignored it. I'll check again but so far I have only seen the plastic pin that goes thru the hole in the battery cable. Unlike other alignment pins in the PS4, this one is stepped to presumably hold the cable up against the motherboard.

I think I may have blown something up, tho. With the battery in, but upside-down, the SP4 powered on. It immediately went into a diagnostic saying the last time it powered down it was done incorrectly. But after a short diagnostic run it came up just fine, just with no battery detected. Now, with the battery in correctly and with no battery at all, it won't even power on. :-(

by

Add a comment

Add your answer

Jimmy Tevis will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 4

Past 30 Days: 23

All Time: 75