Ir para o conteúdo principal

Released on October 23, 2012. Core i5 or Core i7 Processor. Apple Fusion Drive.

209 Perguntas Visualizar todos

Fan Not Working - How do I troubleshoot?

I cannot get fan to run again after removing and reinstalling it in order to swap out hard drive for SSD.

Macs Fan Control app shows 0 rpm current indicating that fan isn’t running.

Fan connector was a bugger to get reconnected; connector kept popping back out.

I opened up Mini again to confirm that it hadn’t popped out and it’s still plugged in.

Fan was working fine before removing and reinstalling.

What can I do to get it working again?

Update (06/20/2019)

Block Image

Block Image

Block Image

Update (06/20/2019)

Why isn't fan running?

I've set Auto Boost rules to Always 20%, but still 0 rpm.

Block Image

Block Image

Update (06/20/2019)

How do I get fan to run using TGPro?

I've opened bunch of Safari tabs to get temp to shoot up, but fan never runs.

Have also gotten push notices to quit apps or increase fan speeds but I don't know how to do that.

Have set Auto Boost Rule to run Always at 20% but fan never runs - always 0 rpm.

See -

Block Image

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1
1 comentário

Take a picture of both the cable connector end and the logic board so we can see the pins. Post them here for us to see Adicionar imagens a uma pergunta já existente


Adicionar um comentário

1 resposta

Pergunta mais útil

It looks like the connectors are OK, so unless one of the wires is damaged I don’t think that’s your issue. Buttoning things back together. Let’s run the onboard diagnostics, process and hold the D key when you restart the system.

Did you get an error? If you’ve updated to the newer macOS you might find diagnostics won’t work. If thats the case the only answer I have is to install TG Pro. You’ll need to pay for the full version to get the diagnostic functions and you’ll need to remove Macs Fan Control as that will compete with TG Pro which you don’t want.

Update (06/20/2019)

At this point I think you have no option than to get a replacement fan unit Intel Mac mini (A1347 Mid 2011-Late 2014) Fan

Update (06/21/2019)

Fan is available in the US store

Block Image

Switch to the US Store and order it from there.

Imagem de Intel Mac mini (A1347 Mid 2011-Late 2014) Fan


Intel Mac mini (A1347 Mid 2011-Late 2014) Fan


Esta resposta foi útil?

Pontuação 1

11 comentários:

I now don't get error message booting into Apple Hardware Test, but get blank screen instead, nothing happens. Any fix for that?

I installed High Sierra on SSD from flash drive installer, just to see if disc would remain HFS journaled. It changed to APFS as online info indicated. So then, I restored original system that was running on HFS drive from Time Machine backup.

When I tried to open Apple Hardware Test, I got error: "Cannot Load EFI/DRIVERS/TestSupportefi"

Why would EFI disappear when it was on the unitialized SSD? Did HFS TM restore delete EFI? I tried to clone from Carbon Copy Cloner bootable High Sierra backup, but don't have the right version to clone to APFS drive.


I had a heck of a time getting Mac to recognize drive in the first place. Crucial support page indicated trouble with High Sierra, so I booted from by external USB backup of old Sierra system instead of High Sierra. I may have missed the "this disc is not intialized" message the first time in Sierra boot (don't think it ever appeared in High Sierra boot), but fortunately, eventually later tried again, saw the initialize message, clicked the button, and chose HFS Journaled, so I could install High Sierra from Apple installer, which of course reformatted drive to APFS.


I can boot just fine into Apple Hardware Test on SATA drive in MacBook Pro 2011, running exact same High Sierra system created on HFS Journaled and backed up to Time Machine.


Tried Option D instead of just D. Got spinning globe (like on MacBook Pro) as if Mini was going to boot into AHT, but then EFI error appeared as before with D Boot. Forgot to mention, that I reinstalled High Sierra from Apple installer and EFI error disappeared from D boot but did not fix, left with blank screen. I thought OSX reinstall was supposed to fix missing EFI?


Apple introduced a bug in the firmware and the newer OS's that messes up diagnostics! You found it and so far there is no solution.


Exibir mais 6 comentários

Adicionar um comentário

Adicionar a sua resposta

dstx será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 3

Últimos 30 dias: 23

Duração total: 3,778