Pular para o conteúdo principal

ThinkPad released in 2011. This version of the T420 is thicker than the T420s and lacks integrated USB 3.0. The T420i uses the same chassis, so most T420 repair guides work interchangeably.

9 Perguntas Ver todas

Thinkpad T420, speakers don't work

Thinkpad T420

  • i5-2520
  • iGPU
  • Manjaro linux

Ever since I bought the laptop I’ve had issues with the external speakers. Initially, they would work for a few seconds when messing with the audio controls before they cut out, now they don’t function at all. According to the volume controller, it’s detecting headphones being plugged in when there’s nothing plugged in at all. The external speakers are listed as “unavailable”.

Block Image

Things I’ve tried

  • Upgrading kernel to 4.18
  • Changing linux distros (I’ve tried Antergos, Manjaro, Ubuntu, Fedora, Mint, and Elementary)
  • Uninstalling and reinstalling audio drivers
  • Cleaning out the headphone jack with a qtip and alcohol
  • Replacing the speakers.

Something I noticed when I first opened it up was that someone probably spilled soda on it as some of it ended up on the motherboard. Really unexpected for a Thinkpad as they have drainage holes through the keyboard. I’m thinking maybe something related to the external speakers was damaged?

Block Image

Thanks in advance!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

Comentários:

Hi Ahmad. suggest you also inspect the mainboard .

Check for any possible corrosion / damage.. etc.

Would be great if you can provide pictures of it

por

Adicionar um comentário

Skip the upgrade.

Take $10 off $50 with
SKIPANDSAVE10

Save Now

Skip the upgrade.

Take $10 off $50 with
SKIPANDSAVE10

Save Now

1 Solução

Resposta Mais Útil

Hi,

Not all the liquid would have drained out as evidenced by the residue shown in your picture.

Is there audio available at the headphones socket?

If there is audio at the headphones socket I suggest that you try and gently clean all of the residue off using Isopropyl Alcohol 99%+ and a Q-Tip, especially where it covers the circuit board as shown in the picture.

As always when working on electronics (except when testing) disconnect the power from the systemboard to prevent any possible problems from occurring due to “accidents”. The Power button is not a power isolating button and power is still available at various points on the systemboard. Also be careful not to damage the board or any components or tracks covered by the residue

It may be that the residue is conductive and is the cause of the problem.

Normally what happens is that when headphones are plugged in, an internal contact in the socket is operated and depending on the type of socket, it either breaks the audio connection to the internal speakers and switches the audio to the headphones or it sends a signal to the BIOS/OS which software switches the audio away from the internal speakers onto the headphones. So given that there is an indication that there are headphones plugged in you are probably right in suspecting that the BIOS "thinks" that there is something plugged into the headphones, when nothing actually is.

If there is no audio available at the headphones socket perhaps the socket (audio board?) is faulty and your cleaning attempt didn’t resolve the problem.

On p.140 of the service manual it shows that there is a audio sub board (part #9 shown on p.134). When searching online using the part number only (04W1623) the part is available. (It seems to be very expensive for just an audio card)

Esta resposta foi útil?

Pontuação 3
Adicionar um comentário

Adicionar a sua resposta

Ahmed Khalil será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 2

Últimos 30 dias: 12

Todo: 110