Ir para o conteúdo principal

A multi-function laptop in the, now discontinued, L640 series by Toshiba.

4 Perguntas Visualizar todos

My network led not blinking

I have serious problem with my laptop

First the network icon is red X and said Not Connected

The network/ Lan led is not blinking,.

Fn F8 which use for turn on/off lan is missing

Is my lan card broken or what? I try for download driver but not solve the problem, now I'm really frustating

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
5 comentários

What OS version are you using?


@richie01 has it worked for you before?



Have you checked in Device Manager to see the state of the LAN adapter? What does it show, working OK, disabled, problem etc?

If disabled have you tried to enable it in Device Manager? (right click on entry and select enable).

If you cannot enable it in Device manager,check in BIOS and see if there is an entry in there to disable/enable the LAN.


I check in device manager and it show nothing, try install driver but show message the adapter is not found, i using win 7


And its enable on bios btw


Adicionar um comentário

1 resposta

Solução escolhida

Hi @richie01 ,

Here is a link to the ifixit dis-assembly guide for your laptop.

Since I'm assuming that you are referring to the WLAN (as you mention trying Fn + F8), at Step.6 in the guide it shows how to remove the wireless card. Check that the wireless card has been inserted properly. If it seems to be inserted firmly then perhaps the WiFi card is faulty and needs to be replaced.

If you search online for a Toshiba Satellite L645D-S4056 WiFi /Wireless adapter card you will find suppliers of the adapter. They don't appear to be that expensive.

Esta resposta foi útil?

Pontuação 3

2 comentários:

i don't know man, i can connect to internet with USB theatring from my phone, but for wifi hotspot its only Show X RED icon, i try to install driver but nothing happen


Hi @richie01 ,

As I said above in my answer you need to check the WiFi adapter card is seated properly and possibly replace it to prove where the problem lies. Your laptop is saying that it is not there.

USB tethering uses different hardware.


Adicionar um comentário

Adicionar a sua resposta

Richie será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 3

Duração total: 634