Not detecting the battery


I've had numerous pro 4's that will not detect a new battery once the original battery has gone "bad physically." The tablet will function almost perfectly when connected to an AC Adapter but the moment it's removed, the tablet is dead.

Every pro 4 that I've come across (over 20 units with this issue) that has had a battery "go bad" by swelling or physical damage was not repaired by a brand new aftermarket (or oem used) battery. I have tried 3 different suppliers (although the packaging is almost identical to one another and the batteries are the same as well) and none have repaired any pro 4's with the swollen or physically damaged battery. The pro 4 will usually say "plugged in, charging" or "charged" with an accurate battery percentage. I can adjust my brightness settings but not the power settings.

I had one pro 4 that the battery just went bad internally, swapped it with an aftermarket battery and all was good. (I tried an oem battery just to see if there was a difference but there wasn't - oem worked as well.) In this case, the bad battery would quickly switch from "0% charging" to "100% charged" with the bad battery.

I've done everything on the internet from drivers to rewriting the bios and nothing seems to help which makes me believe it is damaging or shorting something on the motherboard when the battery damage happens. There are no errors in the device manager either.

If anyone with any insight on this could help, I would (as well as others) be very grateful.

Thank you,

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 1


Have you found a solution?


yes, usually it was one of the two diodes they talk about on this website. The ones that were not repaired by the diode replacement had issues further down the line. Here is the link


Adicionar um comentário