Pular para o conteúdo principal

A series of Gigabit NAS desktop drives of 1TB, 2TB, and 3TB varieties, made by WD in 2010.

7 Perguntas Ver todas

Can I replace Ethernet PCB on this External HD?

I have a Western Digital MyBook external hard drive that recently quit connecting. This is a NAS device, so direct connection to the hard drive does not work, however, the HD itself is still working and files are intact. The problem is that the Western Digital drives are encrypted, so the only way I can see to recover my data from the hard drive is to find a new PCB with the same numbers and connect it to the hard drive so it can connect to the network and transfer the files.

My question: is this the only approach? Or does someone have another suggestion.

This particular PCB number has been impossible for me to find online, so I am hoping someone has a workaround or resource.

I found a thread that describes using an ExtFS driver to mount the SATA drive directly to the computer - when I try this the drive does show up and I can view and access the folders and files, but the drive dismounts intermittently and file transfer speeds are EXTREMELY slow.

Any input from you guys would be greatly appreciated.


Western Digital MyBook Live NAS

PCB Model#: 4061-705086-003Rev. AE

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

3 Soluções

Solução escolhida

All - this is a follow up to my original post with the solution that worked:

After installing and purchasing the Paragon Extf driver for Windows, I removed the HD from the original enclosure, removed the PCB, and connected the HD directly to my PC using the standard power/SATA ports on the HD.

I had to open Device Manager and refresh the list in order to get the drive to show up as "unrecognized". As soon as it appeared in the list the Paragon Driver recognized and mounted in automatically.

At that point I was able to browse through the HD folder tree and see all the files on the drive.

I then simply dragged off the main folder "Shares" onto my desktop and left it alone for a few hours while it copied all the files over to my local HD.

Pretty simple way to get the files off. Still couldn't find a solution for repairing the original PCB, but I'm satisfied with being able to recover the files.

I hope this helps any other unfortunate Western Digital users who are searching for a solution to this issue.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário
Resposta Mais Útil

Hi @v4vendetta ,

Not sure if this is what might help.


Esta resposta foi útil?

Pontuação 3
Adicionar um comentário

I have the same problem. Yesterday I was able to access it with the WD Discovery utility Software. I was able to “Browse Network Shares” and display the shared folder on Windows Explorer that proof it was still accesible. Today I tried the same thing, but had no more access to it.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

vVv será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 4

Últimos 30 dias: 37

Todo: 806