Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Loja

Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1525 Perguntas Visualizar todos

problems stays after changing dc-in

Have a macbook 1.85 GHZ intel Core 2 Duo, Battery won´t charge, no green/ red light. The macbook does take power from the outlet! I changed the DC-in board but the problem continues! Might it be the mother board?

Update

here is what coco says

Battery charge

Current charge: 961 mAh

Max charge: 3865 mAh

24% (yellow)

Battery capacity

current capacity: 3865 mAh

design capacity: 5020 mAh

76% (green)

Mac model: MacBook 2.1

Age of your mac: 48 month

Battery loadcycles: 732

Battery temperature 29.7C

Battery power usage: 0.0. Watt

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

4 respostas

Pergunta Mais Útil

It could be you have a bad battery connector or a bad battery. You can download and use Coconut Battery to check the age, current capacity, and cycles of your battery. If the battery looks good, then I would replace the battery connector.

Update

Battery connectors can go bad over time. No real cause other than usage.

Based on the stats your battery looks fine. Have you tried using a different AC Adapter? I have run into a similar problem with my own MacBook where the MacBook will run off the AC Adapter, but will not charge the battery. I changed the AC Adapter and it fixed the problem. Also, I could fix the problem by bending the cord near the MagSafe plug certain ways. Not sure if that meant there was a short in the wires. I just got tired of having to mess with the cord to charge the battery and got a replacement AC Adapter.

Imagem de MacBook Battery Connector/Sleep Sensor (non-Energy Star)

Produto

MacBook Battery Connector/Sleep Sensor (non-Energy Star)

$7.99

Esta resposta foi útil?

Pontuação 2

Comentários:

+ excellent answer

por

Adicionar um comentário

Test the AC adapter with a multimeter. Look at the tip and use a toothpick to move the pins in and out, (do this while unplugged).

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

Matt, thanks for you reply, but what possibly could be wrong with the battery connector? And why the light of the mac adaptor does not show green or red?

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

mayer, I do have a multimeter but do not understand what should be doing?

The small magnetic plug has five pins and yes I noticed that they move inside when you push...

But what should I be doing with the meter? What should each pin show?

Matt, I used another ac which did not work either so I assumed it was the dc-in board.... but after changing it the problem stayed (used my adaptor on another mac were it worked correctly)

Another strange fact is that my ethernet port does not work either (software says that there is not port present)

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

willem será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 0

Duração total: 960