No power after replacing Power Supply Unit?

Hey guys, so I just took my PS3 upstairs to play at a friends' place and I could get no power whatsoever when I've tried to plug it in since then 9at both my friend's place and mine). No red light on power button, nothing. Tried a different power cord and socket and multiple ways to turn it on but nothing worked so I bought a new Power Supply Unit and replaced the old one which all the internet seemed to proclaim was the likely culprit. However I still have absolutely now power. I've tried a different cord/socket again since then: no dice. I read perhaps there was an issue with the power button itself but I'm not so sure that's the case as I'm unable to turn the console on via methods other than pressing said button (i.e. controller still won't turn it on). Have I missed something important in the disassembly/repair process? I heard there can be a power issue related to some sort of cable/ribbon but I can see a few parts that could match this description and the internet doesn't seem to be yielding photo/video guidance for the apparent cutting you need to do to resolve this issue, if that's even what my problem is. Is that the issue do you think? Could someone actually explain this kinda thoroughly so I can attempt a fix? Anyone who has any troubleshooting advice for the no power/lights issue after the PSU has been replaced would be greatly appreciated. Many thanks in advance!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 3

1 comentário:

Experiencing the EXACT same issue...followed instructions as provided here using brand new power unit: PlayStation 3 Super Slim Power Supply Unit Replacement

...still no power. Anyone with troubleshooting suggestions?


Adicionar um comentário