Ir para o conteúdo principal

Android OS / 4GB Capacity which can be upgraded to up to 32GB / Model A270a / Black and White

80 Perguntas Visualizar todos

USB Device Not Recognized

I've had this phone for over a year. Suddenly, it has stopped connecting properly to my PC. Still charges, but cannot transfer files. Other forums have suggested enabling the USB Debugging in the developer options, but that doesn't work. I've used the Universal UDB driver, but that doesn't work. I've tried returning the phone to factory defaults, but that doesn't work. This problem coincided with the first time I tried to connect the phone after switching to Windows 10, but the phone doesn't connect to an old computer that is still in Windows 7, so that isn't the problem. I tried switching the cable to another cable of the same type, but the same thing occurs, so that isn't the problem. I've also tried the PC suite program - some PDAnet thing that apparently is supposed to allow you to tether with an android phone - but when that was installed on both PC and phone the phone still didn't connect even in sharing the wi-fi signal, so that wasn't the solution either. Does anyone have any other advice?

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 6
Adicionar um comentário

4 respostas

Solução escolhida


Can you visually inspect, with a magnifying glass, that the centre pins on the USB port in the phone are OK? Also check that there is no fluff etc in the socket which may impede the connection. The centre pins are the data -ve and data + ve leads which do the communicating with external sources. Also if possible check if the socket 'feels' loose. Insert a USB cable and very gently see how much up and down and side to side movement you can feel in the socket. Stress very gently. It may be that one (it only takes one for it not to work) data lead is not connecting to the systemboard

Esta resposta foi útil?

Pontuação 2

1 comentário:

Thanks for the suggestions. I'm not an expert, but it does not appear that there is anything out of the ordinary with the pins in that port (hard to count because they're so tiny and close together, but it looks like there are about 5 on the board, and all of them seem to have metal reaching all the way to the end of the board) nor is there any fluff. I tried attaching the cable and testing its limits. It didn't appear that anything wiggled easily - and, as you said - I didn't want to overstress the port. The only thing I noticed is that it apparently connected and disconnected a couple times because Windows gave me the error message (a USB device did not connect properly) a few times. However, after blowing into the port to blow out any possible fluff (holdover from old Nintendo cartridges) it says it's connecting. Who knows, but I'll mark this as fixed.


Adicionar um comentário
Pergunta mais útil

It seems Microsoft is blocking BLU phones for some reason. I guess they think the Chinese are going to steal Bill Gates bank account. It is a travesty to block a device. I have videos and pics that my only option is to download over wi-fi or cell. To !&&* with Microsoft and their Gestapo tactics. I hate this $@$*. Will defeat them bastards one way or another.

Esta resposta foi útil?

Pontuação 3

2 comentários:

Hi @Jeff Noli,

Here is a link that may be of some help to you. Pick your model.


how can fix USP not recognized message in windows 7 can any body help me from that?


Adicionar um comentário

Here is how to fix USB Not Recognized message in Windows 10

After the USB is safely removed from the port, the computer disables the particular port which might be the reason for this error message.

The currently loaded device driver has become corrupt or unstable.

Outdated drivers.

The external drive is entering selective suspend.

The USB controllers have become corrupt or unstable.

Outdated system hardware.


Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

My BLU Advance 4.5 will not access any photos from 2015 via USB. It does access photos from 2014, 2016, and 2017. I'm completely stumped.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

chuckleswheaton será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 7

Últimos 30 dias: 22

Duração total: 22,708