No service after lcd digitizer replacement!? (Tmobile)

Have fixed over 20 GS3s in my day, and this of course is my own personal one. After the screen was replaced, I only get service in WIFI areas. One/Zero bars everywhere else. Replaced sim card and even antennae. Still happening. I noticed a bit of water damage and scrubbed it. STILL didn't help. Any advice please? Maybe software? Or a chip may have broken off? Thanks in advance.

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

4 Soluções

Solução escolhida

Turns out the back housing had accidentally been swapped with a verizon, which seemingly fit, but later would knock the antennae off as well as not matching with some of the important grounds. Thanks

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

Sir can you help me? I have the same problem but I don't know how to fix it. How did you fix your problem?

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Hi Julia when you open it up there is a long cable running up the right hand side make sure it's connected proporly

Esta resposta foi útil?

Pontuação 0

Comentários:

but is it the wifi antenna your are reffering to?

por

Adicionar um comentário

@con arent you referring to the wifi antena?

what antena or part should i look for the network issue?

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Austin Harris será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 3

Todo: 1,725