Ir para o conteúdo principal

The Mac Pro First Generation is an Intel Xeon-based workstation computer manufactured by Apple Inc. The first generation model includes the machines from 2006 through 2008.

318 Perguntas Visualizar todos

incompatibility with Seagate ST3000DM001 hard drives?

Hi All! Sorry I've been away for a while.

I've got a weird one: I have a couple 8-core 2008 2.8GHZ Mac Pros. I started with some 2TB Western Digital drives, which worked fine, but I decided to upgrade to 3TB Seagate ST3000DM001 drives. These are SATA3 6GB/s drives. The first of these drives worked for a while, but after a few days Lion stopped letting me log in. It went to a white screen after entering my password, then went back to the password screen again and I was stuck. Previous to not letting me log in, I had been getting an error when trying to get into system prefs. So I wiped the drive and reinstalled Lion from scratch, and a few days later I noticed that DMG packages suddenly wouldn't open. I rebooted, and again, I couldn't log in. Next, I tried another identical drive on an entirely different Mac Pro, assuming the initial drive was failing and causing corruption. An hour ago, DMGs would not open again, and simple functions like Launchpad are excruciatingly seems obvious that the OS is being corrupted. In each case the machine works for a while, and then the OS eventually fails as the corruption builds.

As I mentioned, I've tried entirely different drives of the same model number, and entirely different Mac Pros with no shared components, and still experienced the issue. I've tried different Lion installer media, and done a clean install each time. I've repaired the disk and permissions. I've run a virus scan on my files. My 2TB Western Digital works fine with my files and software (I'm using it now) and has never suffered from corruption, so I can only conclude that my files/software/Mac Pros are fine, and the issue is with the Seagate ST3000DM001. If I was installing bad software or doing something wrong, it would have affected the 2TB drive as well, because I have treated that drive exactly the same as the 3TB drives. I'm formatting the partition GUID, so that's not the problem.

I've Googled the issue to no avail. This is a SATA3 drive at 6GB/s, whereas the 2008 Mac Pro has a SATA2 3GB/s SATA interface, but that really should not be a problem. I recall that with some laptop drives the jumper has to be set to 3GB/s or weird behavior happens, however this drive does not come with a jumper to bridge its pins, and the manual for the drive does not appear to address jumpers, so I don't know if that is related to the issue. A friend has the 2TB version of the same drive in an identical computer and it has worked fine for weeks.

Anyway, your thoughts would be greatly appreciated. I've been dealing with this a month now and having to rebuild every few days is killing me.



Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 3
Adicionar um comentário

1 resposta

Solução escolhida

I think you've already figured out the problem. I've had no problems with 2 TB drives in my MacPro but haven't tried a 3 TB 5GB drive yet. You may have to get drives that you can jumper down to 3 GB.

Esta resposta foi útil?

Pontuação 4

1 comentário:

You're probably right. I just wish there was more info out there on 3TB drives and Mac's a really popular drive model, and I couldn't possibly be the first person to try this. There is a Seagate DOS utility that lets you go in and set the "jumper settings", so if I get really bored I might throw a drive in a Windows 7 machine and see if it's possible to set the thing to 3GB/s, and then we'll see from there if that's the problem.


Adicionar um comentário

Adicionar a sua resposta

rdklinc será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 12

Últimos 30 dias: 17

Duração total: 4,314