Ir para o conteúdo principal

SanDisk media player with Rhapsody. Physically identical to the e260. Model number SDMX4-4096-A70.

3 Perguntas Visualizar todos

Faulty Battery or Faulty Connector?

Good evening,

I’ve recently dug up my old Sandisk mp3 and thought I’d try to use it again. I ended up using a known-good generic 3rd party Apple 30-pin connector to plug it in into the wall socket. I tried turning it on a few times to see if it would run on power but the same message would appear.

“Battery is too low. System shutdown.”

I even let it alone for 30 minutes but there wouldn’t be any battery indicator or changes on the screen, same message always ends up popping up.

Another thing I ended up finding out was that whenever I wiggled around the cable the ring light-thing would turn on for a very quick second but then turn off. i checked the connector itself and it didn’t seem to have any external damage to the prongs or the connector itself.

Not sure if it has to do with a battery replacement but, I wanna double check myself and see if my suspicions are correct.

Any information or tips are appreciated.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

1 resposta

Pergunta mais útil

Boy, that's a tricky one. Obviously it's complaining, probably accurately, that the battery doesn't have enough charge to work. I think you've done a good job covering the first step, that of making sure your power source is good by using a known good cable and charger.

That leaves us with the two parts you're suspecting, the charging port and the battery. To be honest due to the reaction of the port to your wiggling, it sounds like the reason the battery isn't getting charged is that you haven't got a good connection between the charging port and the plug on the cable.

However, I'm going to suggest trying a new battery first for the simple reason that it's easy to replace the battery and really really hard to replace the charging port. I'd want to 100% eliminate the possibility that the problem is with the battery before I even considered trying to replace that charging port.

There are a couple of issues with replacing that port. First, of course, is the difficulty in soldering a 30 pin connector. That's a lot of pins to get soldered on correctly, so there's a lot of room to make a mistake unless you're fairly experienced at soldering. The second part of that issue is that of locating a replacement port; I did a somewhat cursory search and came up with bupkis, nada, nothing.

So yeah, I'd say your next step should be to swap out that battery. If that doesn't work there's a small possibility a different charging cord may work better; you could try and locate one that's being sold specifically for your Sansa as a suggestion.

Try those out then come on back and let us know what you found. If it's still not working we'll see if we can figure out where to get a replacement charging port for your device and how to replace it.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

Adicionar a sua resposta

nameunlisted será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 4

Últimos 30 dias: 12

Duração total: 34