Ir para o conteúdo principal

Repair and disassembly information for the ROG Ally, a handheld gaming console made by ASUS. Released in 2023 and identified by model number RC71L.

25 Perguntas Visualizar todos

USB-C port not charging with power delivery

A few days ago, the usb-c port of my ally had stopped charging with the provided adapter. It still connects (a white LED shows up when connected in sleep mode), but it will not charge it, no matter what side of the usb I used.

Right now it only charges with low power cables, the kind that you would use for phones, and (as far as I know) only works on one side of the cable. Obviously it means that I can't use it and charge at the same time, I'd have to wait about 8-9 hours just for it to charge 60%. Non-charging cables work as well, but again only on one side.

I took the ally to two repair shops, both of which did nothing to fix the problem (thinking the adapter was the problem). I think it has to do with the port itself, or somehow a bios update. I hope this could get fixed soon, I don't want have to return it.

----------

Edit: Thanks to JiYoW (@luunfmr2mlkysbv) for helping me out! The solution is to try and switch the "batter care" on the MyAsus app on and off a couple of times, and also the full-charge mode as well just to be safe. Then fully turn off the ally, plug in the charger, and then turn it back on, Very simple!

I'll keep this question open in case the solution doesn't work for someone else, and if others have others ways to fix this (hopefully without going into too many repair shop beforehand 😅)

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 2
Adicionar um comentário

1 resposta

Solução escolhida

Hey, I know I'm late to the party but I have the same issue as well when it comes to charging the ROG Ally. However, I may have found a fix for this and I have a hunch on how it started on mine. It may be different for both your cases. To determine if my guess is right, before this started, did you turn on the 'Sleep Care' and 'Quick Charge' function on the MyAsus app before this happened? Mine started acting up after doing this. So the solution I had to sort of fixing it is this. I open the MyAsus app, toggle both options a few times and eventually leaving both off before exiting the app. I then shut down the ally. After the complete shut down, I plug in the charger before turning it on and after a few seconds after booting, it charged again. It's still finicky hence me saying that I sort of fixed it. This would mean that it's a software issue on the MyAsus app.

Esta resposta foi útil?

Pontuação 2

6 comentários:

Hi, upon reading your comment I was intrigued and seeing as though Asus had certified my Rog Ally as e-waste I figured I'd try to see if it is in fact a software issue.

I was able to wipe the intenal drive and reinstall windows 11 and it did in fact seem to fix the issue. What does seem to be causing it (at least when the updates are happening) for me is the AMD display driver as far as I can tell.

Sad to see that Asus are incapable of even basic troubleshooting and repair but there you go.

Process-wise I wiped the drive by using Hiren's Boot CD and then reisnstalled Windows using a new installation USB. I should point out that I had let the battery completely drain as well so I don't know if that played any part in it but there you have it.

por

@ale6is nice! Great to hear that you were able to sort out your issue. I have yet to wipe my device clean and reinstall windows. Might try that at some point just to be sure. %#*@ Asus for letting us have a taste of what handheld pc gaming is only to leave us hanging when it comes to issues like this. I would have thought that they have the knowledge when it comes to this. Turns out, customers are even better at proving support to each other! LOL!

por

omg... IT WORKED! It actually worked!!! thank you so much!

Edit: after some testing, it seems to really work! I'm using a apple high-powered charger, but even though the armory crate said it would not work, it shows as charging in the windows icon. And indeed the percentage does go up, even while gaming. I really can't believe that the solution was this simple the entire time!

por

Honestly goes to show how bad Asus are at troubleshooting their own hardware. Shameful really

por

Asus uses an external USB boot drive to diagnose problems. So any settings in Windows or Armoury Crate would have no effect.

They then wipe the internal SDD and reinstall the default Software.

BIOS settings are also reset.

So it's unlikely the repair contractor actually examined your device.

por

Exibir mais 1 comentário

Adicionar um comentário

Adicionar a sua resposta

Kess8a será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 44

Últimos 7 dias: 226

Últimos 30 dias: 705

Duração total: 1,318