Ir para o conteúdo principal

A1708/EMC 3164 — Released June 2017, this entry-level MacBook Pro retains its traditional function keys (as opposed to the OLED Touch Bar).

565 Perguntas Visualizar todos

New battery not working

Hi,

Added a new battery today and not Good so far.

The device only powers on with power cable connected.

It won't turn on straight away when I press the power button, if takes a minute or so then comes on.

When I originally put the trackpad back and notice a spark, would this device be shot here even of its turning on at the moment?

I've also just ordered another BMC flex cable.

Help appreciated

Block Image

Block Image

Block Image

Here you go on images

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0

3 comentários:

UPDATE - Just noticed I didn't unclip the BMU when removing.

Also, the connector to the battery board came out when installing.

1. Could these be broken if yanked out not pulled out with the clip open?

2. Does a new cable solve this? If yes I'll need to wait a few days till it arrives to conclude on this!

3. My god Apple complicate things on mainboards lol. You need to be Tom Thumb

por

Update - just tried multimeter on new battery and got readings so suggests it isn't a dud battery?

por

So I have a battery working.

# New cable arrived and worked straight away

# Then stopped working when I put the cover back on

# Appeared the connecter clip for the the cable on the battery PCB was not clipping fully down, maybe this battery manufacture that was poor in the first place as it had some yellow film on it to hold it down.

# Reapplying the same tape down with some electrical insulation as now held the clip down

Something also clicked while waiting for the cable and that was that the first time I put the cable in on the original try the Low battery warning came up so this must had worked originally and I'd be surprised that other two cables are even broken tbh.

Thanks for the help. Why Apple put a clip this small in along with it being backwards is beyond me, maybe it's just because they can?

por

Adicionar um comentário

1 resposta

Can you install this gem of an App CoconutBattery then take a snapshot of the Apps main window and post it here for us to see.

Esta resposta foi útil?

Pontuação 0

3 comentários:

No I've tried this and says it's now not supported on mine.

In system report I can't see the battery so can't be installed.

por

@danmacman - I guess we will need a few clear pics of the connector and the cable. It sounds like either one is damaged.

por

@danmacman - what hard to see in your second image it looks like the cable was over flexed cracking the traces! So take a magnifier and double check, hopefully a new cable will correct that.

por

Adicionar um comentário

Adicionar a sua resposta

Daniel será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 3

Últimos 30 dias: 5

Duração total: 64