The arrows and shapes buttons are not working.

Hello. My friend gave me his PS5 controller to fix it since he is complaining that the buttons are not responding and it is not charging. So far I did the following:-

  1. I tried first to open it and find any noticeable issues but nothing so far.
  2. Tried to turn it on but it is blinking blue and closing shortly.
  3. I plugged the controller to the computer and test it online and it seems that all the buttons are responding but the ones are not responding are all the arrows on the left and the buttons on the right (X, square, circle and triangle).

My initial thought are the battery need to be replaced, so I am getting a new battery. But for the not responding buttons I am not sure, my thoughts are that could be something wrong with communication strip at the back of the controller or something else.

Please advise and thank you.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário