Ir para o conteúdo principal

The DualShock 4 CUH-ZCT2 was announced in 2016 to replace the CUH-ZCT1 controller released in 2013. This controller is similar to the previous model.

268 Perguntas Visualizar todos

R2 Trigger not responding at all

Hey guys! So I've had my DS4 for about 6 years now. I didn't use it for a while (about 2 years), and when I plugged it in the other day (I use it on PC, my PS4 doesn't work) the R2 trigger wasn't responding at all. It's not a flicker or a "I have to press real hard" thing: it's completely dead.

I opened the controller to check for any obvious signs (broken plastic, something missing, something burnt), but honestly couldn't find anything. I even took it off and tried pressing the sensor myself and nothing (I did the same with the L2 trigger to compare, and it responded perfectly). I used DS4Windows to test the buttons' response.

So that's the extent of my "knowledge", I don't know electronics enough to really know what's wrong other than what I did. Is there anything else I should be checking? Like something in the motherboard, or maybe a cable/flex I don't know about? I didn't take the battery off to expose the motherboard because I wouldn't know what to look for before asking.

I don't have the money to buy a new one right now (plus the rest of the controller works perfectly), and would like to avoid sending it to a "technician" to be charged a lot for something I could fix myself.

Thanks in advance for reading and any help you can provide!

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 2
Adicionar um comentário

1 resposta

Pergunta mais útil

I got super nosey about the answer to this. I am not a controller expert, but it sounds like you need to do some more teardown. Most of the signals for buttons are carried by a huge flexible sable that surrounds the frame the board is attached to. This is a picture of the front part of the trigger. The blue cable is what ultimately sends the button signals to the controller's board. It could be something isn't quite aligned properly, or the cable is damaged.

Block Image

Esta resposta foi útil?

Pontuação 2

1 comentário:

Thank you for your answer! So I took your advice and opened it up all the way: I cleaned the board front and back, the flex cables, the plastic frame with the flexible that's shown in your picture (mine's green, but it's basically the same one), and pretty much every nook and cranny with isopropyl alcohol and q-tips. Unfortunately, the trigger's still dead, the rest of the controller still works perfectly.

Do you have a recommendation in terms of trying to figure out whether the problem comes from the board or the flex frame? I'm guessing the only next step is replacing something, but I'm still not sure where the problem lies and I don't really know how to figure it out.

Again, thank you for your answer!


Adicionar um comentário

Adicionar a sua resposta

wasivis será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 4

Últimos 7 dias: 26

Últimos 30 dias: 79

Duração total: 349