Ir para o conteúdo principal

The March 2015 update of Apple's 13" MacBook Air features fifth generation Intel Core i5 and i7 processors, resulting in slightly increased performance and battery life.

630 Perguntas Visualizar todos

USB drive not being detected by finder and disk utility.

I was using a usb drive with my Mac and it gave me the notification "improper disconnect" I hadn't touched the drive so I thought it was just the old USB port and it would be fine, maybe some corrupted data, but upon plugging it in it wasn't recognized apart from appearing for a split second as an unmounted drive in district utility. I tried this on another Mac and on a PC but it also wasn't recognized there. I reset the SMC, PRAM, etc. but nothing worked.

I must also note that I think the USB drive is getting power, the indicator light on it lights up and flashing as if it is being used

I have checked the console logs and I think these error were related to the issue:

"unable to repair /dev/disk2s1 (status code 0x00000008)"

"unable to mount /dev/disk2s1 (status code 0x00000047)"

Block Image

these both occurred when plugging in the drive

any help is appreciated thank you.

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

1 resposta

Solução escolhida

You’ll need to get a drive/file recovery app to hopefully get your data, like Drive Genius.

Is this a HDD or a SSD? Also what macOS are you using on the system/s as older Sierra based systems can’t read or access APFS drives only HFS+ drives

Esta resposta foi útil?

Pontuação 1

5 comentários:

The drive is an ssd, just a regular usb stick. Pretty sure its formatted in fat32, not sure if that has something to do with it because it worked fine before. Im using macOS Big Sur

I was able to find it in a disk recovery program, this also gave me a prompt saying that it wasn't mounted to prevent data being overwritten, I tried to mount it but it still didn't appear.

Also recovering the data is not that important to me, I don't think there was anything on it in the first place, I would like to get it to appear so I can reformat, repair, or whatever to use it again.

thank you so much for answering though I appreciate it.

por

@suaru - if there is no data just reformat it within your Windows PC to FAT32 or better yet exFAT

por

I have attempted this earlier but when trying to access the drive, but file explorer would take a bit to load it, then crash and the drive would disappear

Also right-clicking and selecting format wouldn't do anything either, and the drive would disappear.

por

@suaru - Then the drive is cooked😞time for a new one.

SSDs do have a write limit as the cells only have so many times. Small thumb drives tend to wear out sooner as they often don’t have spare cells and the Windows FAT table (all versions) or even HFS+ or APFS have structures that are often rewritten enough to wear the drive.

por

ah, ok thank you very much, I'll look into getting a new one then.

por

Adicionar um comentário

Adicionar a sua resposta

suaru será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 5

Últimos 7 dias: 10

Últimos 30 dias: 18

Duração total: 107