Ir para o conteúdo principal

Repair guides and disassembly information for the MacBook Pro 16'' released in November of 2019. Model A2141, EMC 3347.

203 Perguntas Visualizar todos

Won't boot OS, recovery partition missing, internet recovery get stuck

Good day,

I received this macbook with a broken display. I wanted to check if the board was working, so I physically disconnected the display and connected it to an external monitor. Boot got stuck at about 40%, so I tried a shortcut to enter recovery - but this mode won't open. So I tried internet recovery - a wifi selection screen appears, then it connects and downloads for about 5 minutes, after this time it restarted and got stuck at about 5% loading. So I tried recovery through the apple configurator. I connected the macbook in the dfu and start a restore, it went through - unfortunately I couldn't see what was happening on the screen after the restore was completed, because of that I waited about 10 minutes and then power it off. Then I disconnected the internal display, connected the external monitor and power it on - after starting it shows the questionmark folder. So I tried to install macOS - after trying to start the internal recovery, internet recovery started loading, I selected wifi, something downloaded, but the next loading got stuck at 45% again (like before when loading to macOS). Diagnostics startup shortcut shows ONLY a problem with the display.

I bought a Macbook from a person who had a certificate from an authorized service center with a repair price - I have an invoice and it shows that macbook needs replacement of the display, display angle sensor and the palmrest with the battery, from which I concluded before the purchase that they found that the motherboard was fine during their diagnostics.

What else can I try and what could this behavior mean? Dead SSD?

If so, can I somehow boot macOS from an external ssd ( I am unable to get to recovery mode as I mentioned above) ?

Thanks for every answer

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
Adicionar um comentário

3 respostas

Solução escolhida

After disconnecting the Angle Lid sensor, I was able to enter internet recovery and install the latest operating system. I got an error during installation, but after rebooting I was able to boot normally into OS and everything works. So it seems that the MacBook Pro 16" late 2019 does not boot into recovery or into the OS if a damaged lid angle sensor is connected to the logicboard. Thank you all for help

Esta resposta foi útil?

Pontuação 1

1 comentário:

I’m so glad you were successful! This is going on my list of weird experiments to look into when I have time. I’m curious what part of this process might be affected by that. I have a very educated hypothesis guess, but I cannot let well enough alone. I’ll be sure to update if I ever work anything out.

por

Adicionar um comentário
Pergunta mais útil

So I think this is a bit of a couple of things. And I am quite sure that what you’re running into is less an issue with the device, and more with your network. I’m gonna break this down step by step because I think it’s easy to jump to conclusions, especially when you can’t see what’s on the screen and you’re getting nothing much to go on.

  1. The initial failure to boot properly could be the result of a few couple things. I’m going to call this a one off weird thing for now.
  2. If you ran a restore via Apple Configurator (rather than a revive), this reinitializes the device storage, wiping it to a totally clean slate, so the drive would have no operating system on it since it’s likely still blank. So your output to external monitor that’s just showing Folder with a question mark is expected behavior.
  3. Booting from a USB device to install will not work in this case because machines with T2 are defaulted to disable boot from external drive. You cannot change this without an Admin login for the machine. Which in its current state does not exist, because there is no OS.
  4. Furthermore the reason it’s going to an internet load screen when you select the USB boot is because the Mac is still unactivated. Restoring the firmware removes its activated status, so now it needs to phone phone to Apple to make sure it’s not activation locked before you install the OS and it is not successfully loading the Activation screen.

Herein lies what is probably the issue. Most likely, Apple just hates whatever WiFi network you’re connecting to. It’s a fairly common issue when using Internet Recovery (or other Apple Internet based boot options). I would try using an Ethernet to USB C adapter to connect it to a network if possible rather than WiFi. And verify the WiFi antennas are connected properly.

It could also be that the whatever part has failed in the top case is resulting in CPU protective mode kicking on. Throttling everything down to a crawl, which could also result in the same sort of timeout issue. Just the computer is the slow bit, rather than the network. I am less likely to think this based on you diagnostic results. Typically you would get Power, or SMC errors in diagnostics if that were the case. But it’s still possible. Especially since you mentioned the fans revving at some point.

Sorry for the novel of an answer, but I just want to make sure that it’s not something so simple as this before we start getting into board level issues.

Esta resposta foi útil?

Pontuação 1

6 comentários:

Thank you very much for the detailed answer. I'll try tomorrow to see if it's an internet problem, but to describe the process in more detail as I'm not sure if it could even be an internet problem. After entering the password from the Wifi, a screen with a globe will appear and it will say that the recovery over the Internet is starting. A countdown will appear (in a strange format, 0:04 means 4 minutes, not 4 seconds, as it might seem). This whole process will go without any problems - the loading will get to the end. But then the Apple logo appears and this loading gets stuck somewhere after halfway. That is, the problem is only when loading at the Apple logo, not when downloading on the globe screen. As for the noise of the fans - they are quiet when turned on and gradually become louder during download. Subsequently, when it encounters a stuck(i.e. the loading does not move further), they are gradually muted again. I think the noise is due to it being the highest i9 model known for its cooling issues.

por

@andrejprac54976 Got it. Thanks for the clarification. That makes a lot of sense. So. If it’s actually completing the internet load bar, then yes. That sounds like your network is fine. As for the not loading the following screen, that’s another story.

As far as I understand, the initial load screen with the globe and the timer is Apple downloading the image for whatever mode it needs to boot to. The Apple logo load bar would then be the system booting to the image it just downloaded.

So you’re getting download, but not boot. First thing I would try is an NVRAM reset. Then give it another go. That’s my go to for issues with Internet recovery as a whole. Those NetBoot sort of images can be temperamental. If that doesn’t work, I might try another firmware restore and start all over.

*Quick add on*. There is a recovery mode diagnostic. I’m not sure what menus it works with though so i will have to investigate that when I get home.

por

@flannelist So I tried NVRAM reset - now when the MacBook powers on, there is a chime, before, there was no sound. Also, there is a sound when I connect charger. I tried connecting to ethernet cable instead of WiFi - sceen with globe is now much quicker (2 minutes), but then I still get stuck on Apple logo, fans stop spinning and it is stuck :-(

por

@flannelist I have a good news. I tried to disconnect angle lid sensor, because it was also listed as bad component in the invoice from Apple authorized service provider and I was able to boot to internet recovery. Now macOS ventura is installing, but it shows that it will take 2 hours. I will let you know how it went.

por

@andrejprac54976 Hm. That’s curious. That was a solid idea though. That model usually necessitates the display and lid angle sensor are replaced together (at least per Apple, due to some calibration of the magnetic sensor on the cable. So I didn’t even think anything of it when that was mentioned as bad. I wonder if during boot to recovery it was checking for something and was getting kicked when it got to that sensor. Now I’m really curious.

Sounds like you’re on the right track. Ventura almost always says about 2 hours to install for me. I doubt it will take that long. Those countdown timer estimations are abysmal . Crossing my fingers you were successful.

por

Exibir mais 1 comentário

Adicionar um comentário

I’m suspecting you are hitting a known issue with Internet recovery as the version of MacOS being installed via recovery is older than what the system is running. This is due to Apples changing to APFS from HFS+

You will need to create a bootable OS installer thumb drive with the proper macOS on it to then repair the drive.

To create the installer you’ll need access to another Mac system to format the USB drive GUID with a journaled file Shem (also called extended in newer OSs) and then set it up from this second Mac, download the OS installer file from here How to download macOS copy it to your USB thumb drive, then follow this guide Create a bootable installer for macOS

Esta resposta foi útil?

Pontuação 0

11 comentários:

Thank you, you gave me hope! I am going to create that USB right now and let you know what I found out.

por

Just for info - mac os bootable USB will itself contain mac recovery partition, so I will be able to install? Because when I tried to boot Windows bootable usb from boot menu, it wanted to run internet recovery first.

por

@andrejprac54976 - Please note the added info as you were quicker than me😊

por

@andrejprac54976 - Boy your quick! The added info is the needed process and steps.

por

Thank you I am downloading macOS from App Store on a second macbook as yours articles advised. I hope 16GB USB will be enough, because that dmg file is relativly big compared to Windows. Thank you I am downloading macOS from App Store on a second macbook as yours articles advised. I hope 16GB USB will be enough, because that dmg file is relativly big compared to Windows

@danj So I tried it, I created bootable USB, then entered boot menu, my macOS bootable installation appears, but when I choose it, I imidiately get prompt to connect to WiFI and when I do, same starting internet recovery screen appears.

=== Update (05/23/23) ===

Now it gets stuck at around 60%. Fans are spinning very fast during internet recovery download and during boot but when it gets stuck, they slowly stops and computer is quiet.

por

Exibir mais 6 comentários

Adicionar um comentário

Adicionar a sua resposta

Andrej Pracovný účet será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 1

Últimos 7 dias: 6

Últimos 30 dias: 61

Duração total: 583