Ir para o conteúdo principal

Lançado em 22 de setembro de 2017. Modelo A1863, A1905. Disponível com GSM ou CDMA / 64 ou 256 GB / Dourado, Prateado e Cinza Espacial.

872 Perguntas Visualizar todos

Home button doesn’t work/ repeat presses

Bought this phone on eBay to fix up/use for parts/whatever I could manage, so history is limited, but here’s what I know.

When I originally got it, it was not powering on at all. Looks like the previous owner attempted a battery replacement, which did not solve the power issue. Because the issue was that there was a cracked VDD_MAIN capacitor (C7609_W if that’s relevant). Removed the capacitor in question.

Device boots up. Functions fine. Except the home button. Does not work. Touch ID is great, but I was not getting any response out of the home button at all. Pretty sure I got a response the first time I pressed it after power on, but seemed extra sensitive? Though the battery actually does need replacement and the flex/connector is a bit wonky (I presume the previous owner put the original battery back when a new one did not work) and so it’s been touchy about staying on when it’s only assembled loosely, and it shut off after the first boot up. Then after it came back on. No more home button function.

Diode mode readings on that connector were a bit funny on a couple pins on the right side. After poking around a bit and accidentally knocking off, and subsequently replacing a resistor trying to clear up all the stuff covering the components around the connector, I thought I would try to replace U5890 (Mamba power). I used the equivalent chip from an iPhone 7, since that’s what I had on hand, to transplant, the schematics seems to indicate they are the same (although the markings on the IC are different, I know that may mean nothing). After that, diode mode readings were almost spot on. And home button function was restored, kind of. But it presses 3 times for every single press. And touch on the display doesn’t work any longer. Which seems more consistent with the first time I powered on. And now again, no home button. And no touch.

I will probably give everything a good looking over when I get home. But I’m at a loss. I wonder if the home button itself might be bad? Is something killing stuff? Is the chip not compatible?

UPDATE 4/27/2022:

So per the suggestions in the comments, it seems plausible this is related to the home button FPC on the board. Connecting just the display connector restores touch. Bending back the ground pins on the home button FPC resulted in breaking one of the pins altogether and replacing the FPC resulted in melting the replacement while putting it on the board (that'll teach me for getting fussy about perfection). Waiting for new connectors to arrive, but strongly suspect that's where my issue lies. Will update when I know more.

UPDATE: 5/4/2022

Replaced the FPC on the board. Got touch back on the display. But still no home button, only touch ID. Did a much more thorough inspection of the flexes on the display and did not find any damage to the traces. I am suspecting the home button itself is at fault, even though nothing looks amiss. Will keep poking at this for fun and update when I know more.

UPDATE: 6/2/2022

Yep, still plugging away on this. It's been a fun pet project. Have verified the button still does not work with a new display. Bought a generic, home button function only, replacement button, which works flawlessly. So for sure an issue with the button itself. Still cannot see any damage to the flex. Replaced turtle IC and no change. Running out of options. Wish it were easier to actually pop the button open. Figuring something about the capacitive sensor itself is busted, or there's flex damage I just can't see.

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 2
2 comentários

Check turtle IC under the scope.


@imicrosoldering It looked okay, but replaced it anyways. Still nothing. This poor flex is looking less than stellar after so much troubleshooting. But Touch ID still works. So I haven't made the problem worse. Yet. I'm mostly just poking at it now out of pride. I wanna fix it and the fact that I cannot see why it doesn't work is just getting under my skin. 🤣


Adicionar um comentário

2 respostas

Pergunta mais útil

These symptoms can happen when the end ground pins on the touch connector get bent in too much. I have seen this several times on the iPhone 8 after numerous connecting and disconnecting of the connector. I usually pry them back out with a thin needle.

Block Image

I have stopped repairing home buttons but I did find this info handy from Ben Duffy.

Block Image

Esta resposta foi útil?

Pontuação 2

1 comentário:

This sounds like it may well be the case. And I have heard that before, just totally slipped my mind.

I had just laid down for the night when I saw this. Got up and tried to sleepily bend pins back. Because I can't just sit on that knowledge without at least trying. And broke one of the pins off altogether (it was looking pretty sad to begin with). Guess I'm replacing the FPC tomorrow if I have one. And then I'll see where that gets me. Thanks for the idea.


Adicionar um comentário

Try unplugging the home button connector all together. If an iPhone 7 home button cable is plugged into an iPhone 8 connector, there will be issues with touch and home button because the connectors are very slightly different. If touch works afterward, I have an idea of what might restore touch function and possibly home button function. I hope this helps!

Esta resposta foi útil?

Pontuação 1

1 comentário:

This definitely sounds like it might be the case. I will give this a go tomorrow. Between me and the other person who did who knows what previously I'm sure that connector has seen better days.


Adicionar um comentário

Adicionar a sua resposta

Alisha C será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 1

Últimos 30 dias: 7

Duração total: 176