Ir para o conteúdo principal

Anker PowerCore III Elite 26k 87w not working!


My power bank is not charging my devices. If I press the single button it has, no lights turn on. But, as soon as start charging the power bank, all lights turn on telling me that the power bank is fully charged. There are no screws in the power bank, and I am not sure how to take it apart to see if something is loose or to check if any component has a short! Does anyone know how to fix this or knows how to take it apart?

Responder a esta pergunta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 3
8 comentários

got the same problem, did you solved yours?


I have the same problem, did you solve yours?


Not really. I hear a clicking sound in the inside when charging. But have not yet tried to open it up.


Same here

There is a clicking sound. I did not open yet, as I do not know exactly what to do after that. I guess we are not the only ones. haven't been able to reach a person at Anker yet


@Paz Tichover there might be a coil that is clicking but there really is not much in this power bank. All you have are 8 18650 cells and the battery controller board. We really would need to see the board to determine what may be clicking.


Exibir mais 3 comentários

Adicionar um comentário

1 resposta

Pergunta mais útil

From my previous experience in power banks, they're not easy to open and opening will often destroy the casing of the power bank(it's probably better just to buy a new power bank) .

I would push a spudger or similar into the gap between the top and bottom casing of the power bank, then try to push a pick in the gap to separate the 2 parts.

Keep in mind that puncturing Lithium ion batteries can cause toxic fumes, fire, and other physical harm.

Esta resposta foi útil?

Pontuação 2

1 comentário:

Adicionar um comentário

Adicionar a sua resposta

Jos será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 27

Últimos 30 dias: 118

Duração total: 3,992