Ir para o conteúdo principal

Liberado em abril de 2010 com as opções de processador i5 de 2,4, 2,53 GHz Core ou i7 de 2,66, 2,8 GHz Core

573 Perguntas Visualizar todos

How can I force output to an external display during boot?

I need to have all output go to an external display. Including boot. The normal display isn’t working so I need to see the boot process and check for problems. It gives all indications of running and booting but no display,

It had been running fine with an adapter from the minidispiay port adapter to vga monitor.

yes, i’ve read, but not understood, all the articles.

+===================================

UPDATE:

++++====================================

Replacing the hard drive with one known to boot has a startup screen. With the previous drive in an external enclosure I installed the OS again and ran DISKUTIL to check for any file errors. Unfortunately it wasn’t just reinstalling the OS, it seems to have installed it over the prior. That’s just my guess since it boots now into a login screen asking for userid and password with no prompts or hints. I’ve tried combinations from the prior install and nothing unlocks the screen. There’s no wifi icon so I believe it’s not on.

None of the startup commands are visible on the external monitor. So my only option is to move it to another machine or to guess the user/password combination. So I’m asking you if you know or could guess a default user Apple has for these cases.

=====================================

UPDATE: 2/13 12:57

=====================================

It becomes more complicated. There may be a problem with the MacBook Pro’s disk subsystem. The new disk I just put in can’t be erased with DiskUtil because it complains there’s no firmware partition. I’ve used First Aid twice same as erasing twice. The original disk was erroring out as well. It’s more strange because DiskUtil says the drive is 750GB while the manufacturer label says 500gb.

Of course if I simply let the 500/750gb drive simply boot, it displays a generic prompt for USERNAME andf PASSWORD. Despite or in addition to Dan and my bewilderment, I never finished that install nor did I create any user. Which might be the reason. Of course I tried the one user always created, GUEST. No go.Nor any of those from my other installs.

All this because I pulled loose the display connector on the logic board. I’ll be working onit all this afternoon

DEVELOPMENT: Seems that having the boot drive be my SSD is causing the no firmware error. Also, I have some USB Flash drives setup as install drives. One must have gotten set as the startup drive. When it’s in, things boot and don’t if it isn’t.

This is just another day in Alice’s Rabbit Hole.

=====================================

Last Update

====================================

It’s been ridiculous, but it ended finally when I had the original drive back in the mac and then used an install USB to put the OS )High Sierra) on. Hopefully I’ll remember the steps it took. And remember that you activate the external as primary two ways” close the lid after turning it on.

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário

1 Resposta

Pergunta Mais Útil

Plug in an external keyboard and mouse and close it up.

Esta resposta foi útil?

Pontuação 3

Comentários:

I'll try it again, but that's not worked. I'm getting afraid that it's stuck somewhere in booting.

FWIW I hear the chime, the "lid closed" light is on, external keyboard attached. No display. Also no backlight on keyboard.Running High Sierra.

por

@capwalker666 consider trying a couple of more things:

a. reset the NVRAM/PRAM:

1. Shut down your Mac.

2. Press the power button, and as soon as you power up the laptop, hold down Command-Option-P-R.

3. Keep holding down those keys for about 20 seconds. Then let go and allow your Mac to continue starting normally. If you have an older Mac that chimes at boot, hold down the keys until you hear a second startup chime.

b. try booting into RECOVERY, COMMAND-R or OPTION-COMMAND-R (for internet), if it boots here, then at least you know your system isn't stopping at something hardware related.

por

The NVRAM reset sounds like a good next step, I'll go try that.

BTW: I found the trick for making a monitor the primary in system prefs. But I need it to take the place of the one that came with it. In my first board level repaair, I had pulled the monitor connector bracket from the logic board. New monitors didn't work and I'm not paying for a new logic board just to get a monitor...

por

the reset seems to change the response but being blind ...

I also tried the recovery (cmd-opt-r) for 2 minutes with no change. Tomorrow (I'm EST) I'll try longer...

por

Well I got antsy with now three computers on the bench and tried your suggestion one better. Reset SMC then NVRam, then 2 minutes of CMD-Opt-R. I can tell all drives are being read now, but no boot up.

por

Mostrar mais 15 comentários

Adicionar um comentário

Adicionar a sua resposta

James Walker será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 1

Duração total: 72