Ir para o conteúdo principal

The larger of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

453 Perguntas Visualizar todos

It wont turn on, unless I disconnect the battery!

I was working on my mac normally until a late hour, then the next day I tried to turn it on but in vain. I tried the SMC, the light goes green and then start charging normally but the Mac doesn’t start! I unscrewed the back and disconnected the battery and plugged in the charger and it starts normally, so I reconnect the battery and worked on the device even when I unplug the charger, however when I turned it off, it never turns on again!! therefore, on every time I need to turn it on, I have to unplug and replug the battery :(

By the way, when it is on, I can restart normally but after shutting it down, it will not turn on until I unplug the battery! When I click on the battery icon, it shows service recommended despite the fact that I can work on my device for over 5 hours before it goes dead.

Please help me

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 2
1 dos comentários

I have a brand new battery in my A1466 and have the exact same problem. I MUST unplug the battery to turn it back on.

por

Adicionar um comentário

3 respostas

Pergunta Mais Útil

Given the age of your system its likely your battery has failed MacBook Air 13" Mid 2013 Battery Replacement

Esta resposta foi útil?

Pontuação 1

3 Comments:

Not a very helpful answer.

por

There was enough to come to a conclusion. Older systems and forcing SMC to get the system to respond is a sure sign the battery is past its prime.

por

I am having the same issue with my 2013 MacBook Air, so I got a brand new replacement battery and the issue is still occurring. Anytime I shut it down, it won't start back up again unless I open it up and disconnect then reconnect the battery. The battery still holds a charge for hours, I just can't shut it down without having to open it up again.

por

Adicionar um comentário

I have the exact same issue you describe.

My Macbook Air will only power on, when I disconnect and reconnect the battery, after a shutdown.

It wakes up perfectly from sleep, and the battery is healthy. The issue is with power down.

Resetting SMC doesn’t help.

I have not found a solution for this.

Esta resposta foi útil?

Pontuação 1

3 Comments:

Let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question

I think you'll see your battery is also likely at its end if you where doing the exact same thing.

Determine battery cycle count for Mac notebooks

por

Just fixed the problem. I took apart the computer. It turns out that the mousepad connector looked a littled like they had rusted in the pins. Very hard to see with no magnifying glass around.

After realizing I could turn on the Macbook, after applying pressure on the connector, I actually ended up solving it by lifting the cable a little bit, pulling the connector itself up a bit. Like it released the socket/connector from a little short circuit.

Would be nice to have Louis Rossmann, check it out.

It works for now. Shutdown to Power on, again. Tried 5 times now.

por

@tremble - I would still recommend you check the battery.

Sounds like you had some liquid/moisture damage.

por

Adicionar um comentário

I have the same problem. My 2013 MBA battery failed in 2019, which I diagnosed by disconnecting the battery and discovering it restarted on mains power. Replacement battery from Replacebase lasted 2 years before swelling up, but during that time, whenever MBA was fully closed down or ran out of charge, I had to unscrew the back and disconnect battery before it would restart. Now in 2021 onto my third battery (£65 “genuine” Apple/SMP battery from eBay … haha), that problem just got worse, as (a) it won’t re-start when it’s cold (<15 celsius), and (b) discharges more easily as I avoid over-charging for fear of battery swelling/fire.

I had to replace the hard drive in 2020 with a 3rd party (Sabrent) drive, which definitely messed up the sleep/hibernate modes, as system usually reboots instead of sleeping. However, since the latest battery change, that might also be why it’s fully closed down. (It’s hard to be sure of exact cause as my 11-year-old would never admit if she let the battery run out etc).

Any ideas why it won’t restart until battery has been disconnected? A couple of people over at Stackexchange also puzzled by this issue. I doubt it’s the power supply board. Please don’t say SMC reset etc. I suspect sleep/hibernate software conflicting with weak battery power delivery.

(I just managed to restart it from cold after it initially failed to respond to power button: I quickly closed it, warmed it slightly by hand and it booted the moment I attached power lead… interesting!)

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

ِAlan será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 11

Últimos 30 dias: 68

Duração total: 968