Ir para o conteúdo principal

iPhone loops apple logo after battery replacement

hello i just bought a replacement battery because my old battery didnt last at all. so i bought your kit for it and watched a video on how to install it and i got it installed perfectly an everything worked, i put it back together and it turned on. it was at %50 and it eventualy died then when i went to charge it , all i got was the apple logo staying on for about 5 seconds. so i tried putting it into recovery mode but as soon as i unpluged it from the wall 3 seconds later the screen went black. so i retried and retried , im not seing a low power icon its just the apple logo repeting and repeating. so i opened it up again and reset the battery plug, and still kept repeating. i tried following this tutorial here ----Flashing white screen after battery replacement

but to no avail. they said it was a seating issue . which in my case it wasnt because it was working fine before it died, they also said if that didnt work it was a faulty battery

any help would be greatly appreciated thx

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário

2 respostas

Pergunta Mais Útil

It sounds like a faulty battery to me. You should contact iFixit directly (not the answer forum) and tell them to send you another.

Esta resposta foi útil?

Pontuação 1

Comentários:

would i have to pay for another one?

por

and also how do i contact them.......thanks troy

por

ONE MORE THING and the battery was working so i dont understand why would it be faulty if it was in fact working

por

I don't know if you would have to pay for another one. I would assume not since the one they sent you didn't work, where the old battery did boot up. Here is a page I found where you can contact iFixit to see about a warranty swap: https://help.ifixit.com/category/133-con...

The new battery never worked right, only the old one. I think they sent you a bad new battery.

por

Adicionar um comentário

Sounds like either a bad battery, or damage from the disassembly. Hopefully just a bad battery! Quickest way to test is to install the old battery and see how it responds. If it boots up fine, bad battery, if it reacts the same, it is either the new faulty battery or board damage.

Esta resposta foi útil?

Pontuação 0

Comentários:

funny thing is that i acidently destroyed the battery sooooooo

por

Adicionar um comentário

Adicionar a sua resposta

MfreakTV “MfreakTV” será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 0

Duração total: 48