Opened device. no image on screens.

hey team.

I had a surface pro 3 screen come in with cracked glass, and a malfunctioning touch panel, but was getting an image.

I ordered in a new screen, and preformed the repair. We started by turning off the device, and put it into a mobile dryer (RG-202F), as we do with many other tablets. Once the adhesive was loosened, we removed the display assembly from the frame. Before disconnecting any of the screen's flex cables, we began by removing the battery flex. we disconnected it, and put thermal tape around the connectors to prevent any accidental short on the screen, or housing of the device. We then continued with the procedure, by disconnecting The two Assembly Flex Cables. We transferred the Primary Display Flex, to the new screen, and applied the screen to the flexes to the board. only then, did we reapply the battery. Now, on attempting to boot the device, we get no image.

At first, i thought it was solely a dead battery, so i attempted to charge it up. The charger lights up with its LED on the side, and the device will let me charge my phone, even while disconnected from the AC Adapter. the device appears to boot, however, we are unable to test an external display, as the HDMI out port seems to have been damaged from the initial drop. We have tried two screen assemblies, as well as the original screen, and it does not get an image on any of them. We have insured the revision and part number match, and that the alignment of the Pin Extension Pads is correct. We are unable to figure out what caused this failure, as the procedure followed, has been the same as every other time we have done a surface. I have personally scanned the board for physical issues, and have seen no scorching, or chipping on components, and every component appears to be in place. There is no physical damage to the PCB either. From what i can tell, There is no issue with the backlight itself, as when holding it into the daylight, i do not see even the faintest image on the device.

I have run the device's LCD connector diode rating checks, and they are all comparable to the device's thresholds.

If somebody out there has experienced this before, and has had the luxury of fixing it, i would very much like them to get back to me with the process that they followed to do so. this is stumping our store, and we would like to get this back to the customer ASAP.

Responder a esta pergunta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0
Adicionar um comentário