Ir para o conteúdo principal

Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

545 Perguntas Visualizar todos

name is too long or includes some characters that are invalid on the..

Good evening,

I have an issue with a hard drive I had removed from my laptop: MacBook Pro 17" (Mid 2010).

It was working perfectly, I just wanted to replace it with an SSD drive.

Later, like 3 days ago, the drive unexpectedly started to give an issue. I think it has bad sectors and because of that, I cannot boot from it as an external drive to use my alternate operating system (as an additional computer - connected to my laptop).

Important Note: When I connect it as external drive, I can see it, but right away there is a window that appears with the next message:

macOS can’t repair the disk “1TB Macintosh HD”. You can still open or copy files on the disk, but you can’t save changes to files on the disk. Back up the disk and reformat it as soon as you can.

Block Image

This hard drive has 1TB ( 2.5" Inches), it is divided into two partitions. One of them works perfectly and on the one that has the issue, I am able to see the files, but it won't let me modify or rename anything on it (I’ve moved 75 Folders from 78), the weight of those folders sums 260 GB, and the remaining (3 Folders) weight 235 GB ].

Now I am trying to move and/or save the rest of the files and documents that are into this partition, but when I try to move the files to another disk, those three folders, and files, the system doesn't allow me to move them.

The next message comes up saying: You can’t copy the item "because its name is too long or includes some characters that are invalid in the destination volume".

Block Image

On Disk Utility, I’ve done the ( First Aid ) option and there comes up the following result:

First Aid process has failed. If possible back up the data on this volume.

Click Done to continue.

Verifying storage system...........

Disk full error

The volume 1TB Macintosh HD could not be repaired.

File system check exit code is 8.

Restoring the original state found as mounted.

Problem -69842 occurred while restoring the original mount state.

File system unable to verify or repair failed.

Operation failed…

Block Image


Basically, the most important for me right now is to save urgently is whats in the last Three Folders and some remaining files that I am not able to modify or rename it to make the "name short and without any special character", so because of it, I cannot move them to the new hard drive unit.

Please, if somebody is capable to help me on this, I will appreciate it so much !!

Update (04/29/2018)

So, this is the way on how I'm trying to move the files from the old HD to the New SSD HD. But the system does not allow me to transfer the last (3 folders) that I need to move. The window with a message comes up saying I cannot do it because the name of various files is too long.

Important note from me: Like I’ve described on the first post: The old hard drive justs let me see the files, but won’t let me rename them or make any changes.

And then, the big question is: How could I get those (3) Folders Out of the Old Hard Drive, if I can’t rename or edit the names on those specific Folders or Files?

Thank you much again !!

Update (05/01/2018)

Hi Dan @danj , I've already wrote this current message on a comment, bur for some reason it doesn't appear on the history :/ But, well... Down here I am answering to you the questions you've sent to me and also, I am sending the ScreenShots you've suggested also.

• What is the Mac OS your system is using ? Go to About this Mac where it tells you.

Answer: The Old Hard Drive ( The one I’ve took from the Laptop ), On the ( 1st ) First Partition, it has [ Mac OS Sierra ] installed.

Note ::: This old one is also 1TB, but not SSD.

• What if any other OS's are you using ?

Answer: The Old Hard Drive ( The one I’ve took from the Laptop ), On the ( 2nd ) Second Partition, it has [ Mac OS Lion ] installed .

Note ::: This old one is also 1TB, but not SSD.

• How did you setup the SSD ? Did you use the Mac OS installer or clone your drive ?

Answer: On the New Hard Drive ( The one I’ve already installed into my Laptop ), I’ve installed [ Mac OS High Sierra ]. 

> I’ve installed the Operative System through the Recovery Mode and the the that Operative System from the Apple Servers.

Block Image

• Did you use Migration Assistant ?

Answer: NO.

• What is the Make and model of the SSD you installed ?

Answer: 1TB Samsung SSD 850 EVO Media

• What are the HDD's partitions are they both GUID/Journaled ? Open Disk Utility and click on the drives

Answer: YES, both are GUID/Journaled

Now I need you to supply me a snapshot of the file dialog box of one of the files on your SSD open up text edit and create a new file, save it, then within the OS Right click on this file, open Sharing & Permissions take a snapshot of the dialog box within the tabbed section.

Block Image

Now open one of the files in question on your HDD, and do the same.

Block Image

Also open the Name & Extension tab and take a snapshot of the name.

Block Image

Respondido! Ver a resposta Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 0
1 comentário

Lets back up here a bit as it would help knowing what OS's you are working with. You replaced your HDD for an SSD and you installed what OS on the new SSD drive? You talk about using the old HDD as an alternate boot drive, do you have a different OS on it? MS Windows, Linux or Mac OS. Also, what is your new SSD make and model?

Lastly, on the hardware side, you have two partitions on the drive are both MacOS GUID/Journaled or something else?

Where are you copying the files to? I hope you're not moving them between the partitions. You need to get another external drive to move your files to as the one with the corruption will need to be completely wiped down to salvage it if it can be.


Adicionar um comentário

2 respostas

Solução escolhida

Have you tried the "cp" command from the command line?

For example,

$ cp -av /Volumes/"1TB Macintosh HD"/FolderA/* /Volumes/XXXX/FolderB

Note: Substitute "XXXX" for the name of your SSD drive or some other backup drive. You can find this out by typing the command "ls /Volumes"

If you provide the -av option, it will continue copying even if errors are detected, and keep a log of the errors and of the files that were successfully copied. Here is an article explaining the process:

Hopefully, this will copy the bulk of your files over, and leave you with only a few of the files where "its name is too long or includes some characters that are invalid in the destination volume" - let's call them bad name files. Then, you can individually copy each bad name file while reassigning it a good name.

For example,

$ cp -av /Volumes/"1TB Macintosh HD"/FolderA/ /Volumes/XXXX/FolderB/

Follow these steps for each of the 3 folders that you want to copy over.

Esta resposta foi útil?

Pontuação 1

31 comentários:

Hi Tim @tdunc15 , Thank you for be interested to find a way to resolve my issue. One question: This process should be done from the hard drive that has the issue or it could be from any computer? .. I am asking because the hard drive that has the 3 Folder that I need has the Bad Sectors I think. that hard drive just let me see those files, but it won't let me modify them. Also It won't let me boot it on my computer. I just let connect it to my computer as External Drive.


@tdunc15 - Tim, David is past that step as the folder/file name is corrupted. As he has an upgraded drive (APFS) running High Sierra and the other drive is Mac OS Extended (Journaled) prepped under Sierra. Then to add to this David has two different user accounts in play between the drives. So this is a bit of a tangle ;-}


@david007 @danj - David and Dan, perhaps I'm misunderstanding: David installed a new SDD into his laptop running High Sierra, and it appears he wanted to be able to boot from the old HDD externally. However, due to corruption issues, David was not able to boot from the old HDD, so now I understood that he is trying to salvage files from 3 folders on the old HDD.

Now, David says he can "see" the files on the old HDD, which I interpret to be the laptop can read them and at least some of them are not completely corrupted, but he runs into an filename length and illegal character error when he tries to copy them from the old HDD to the SSD (agreed this is probably due to the APFS vs. Journaled format). I wanted to propose a simple way that might work to salvage some of the files on the old HDD.

David, to answer your question, boot up your laptop, then plug in your old HDD so you can "see" the files, and then try to perform the copy as I outlined.


Hi Tim @tdunc15 - Dan @danj - Tim, you are right.. I think you’ve understand what is exactly happening. Concerning the New SSD Hard Drive I've installed into my Laptop ( The one that has High Sierra ), lets forgot about it for a moment... The last ting I was trying to do this afternoon is the following: I took the Old Hard Drive and connected it to another computer as ( External ).. Also, I took another external hard drive ( Segate 4TB ).. and through that computer ( Not my laptop with the SSD HD ) ( Just another Mac [ iMac ] )... and I was trying to copy those (3) Three remaining Folders, ( From the Old Hard Drive - Used as External ) and to copy and paste to the other External Hard Drive, and it is happens the same thing. It doesn't make the action of paste. The same message appears saying: You can’t copy the item ” “ because its name is to long or includes characters that are invalid on the destination volume. --> It continues on the second Post...>>


<> Please review the Post before this current one. - But, like I’ve wrote on almost all my posts: The Hard Drive where it is the Folders won’t allow me to modify the name of the folders, it just let me see them. Note: If that Hard Drive let me modify it, I do it. If yes, then I could transfer or copy and paste those folders to my other External Hard Drive. So I don’t understand why I need to go through install Operative Systems and all those things and make that so difficult, if it is just an issue about the name of the archive ?


Exibir mais 26 comentários

Adicionar um comentário
Pergunta mais útil

Let's try again: Focus on my questions here. I understand your problem but I need to know these things to help you.

  • What is the Mac OS your system is using? Go to About this Mac where it tells you.
  • What if any other OS's are you using?
  • How did you setup the SSD? Did you use the Mac OS installer or clone your drive?
  • Did you use Migration Assistant?
  • What is the Make and model of the SSD you installed?
  • What are the HDD's partitions are they both GUID/Journaled? Open Disk Utility and click on the drives

Now I need you to supply me a snapshot of the file dialog box of one of the files on your SSD open up text edit and create a new file, save it, then within the OS Right click on this file, open Sharing & Permissions take a snapshot of the dialog box within the tabed section.

Now open one of the files in question on your HDD, and do the same. Also open the Name & Extension tab and take a snapshot of the name.

Follow the instructions here on how to add your files: Adicionar imagens a uma pergunta já existente

Update (05/01/2018)

OK, I see a few issues here. The first is unlike Sierra, High Sierra uses a new file system GUID/APFS vs GUID/macOS Extended (Journaled) which in truth is a version of HPS+ Apple File System FAQ: How APFS works with older Macs, encryption, external drives, and other questions. It still has some issues which maybe whats hitting you with the length of the file name and the language.

I've seen issues with it running on older SATA based systems as its got some issues with queueing within Finder Apple seems to be side stepping. I've altered them a few times in the Beta system and still haven't seen any improvements.

If its not to late I would recommend you save your data onto a new external HDD drive (just so we don't alter your internal HDD you've pulled from your system) with anything it doesn't have. Then wipe the SSD drive down and this time lets install the older Sierra OS.

I would first create an OS installer USB thumb drive following this guide: How to create a bootable macOS Sierra installer drive Then using it to launch Disk Utility first to wipe the drive and start again with the OS install process.

Lets jump a bit here and come back to the OS install...

You have a second issue which I think is also going to mess you up. If you look at the file permissions you've got two distinct user accounts as you didn't migrate your account over. While you can add-in the new user account to each file I think its just easier(and more sure to get all of the needed files) to allow Migration Assistant to do all this work. So, with a fresh OS install at the very end the installer process it asks you if you want to migrate your user accounts, apps & data over using the setup assistant (which is the same as Migration Assistant). This is when I normally do it, or if I want to finish updating the OS and built-in apps I can come back and do it afterward using the utility Migration Assistant.

Within Migration Assistant you can copy over not only your user accounts, you can selectively copy over your apps and data files from one or multiple volumes or drives (you just need to run it a second time). Here is a bit more on how to use Migration Assitant: Your Guide to the OS X Yosemite Migration Assistant its the same across all of the versions of MacOS.

Esta resposta foi útil?

Pontuação 1

16 comentários:

I have been trying to answer your questions and suggestions by ( Posting a Comment ), but the page won't allow me to do it. Please review the reply message I've posted to my own question / post. Thank you so much Dan @danj


That's correct, the comments section won't let you post files. That's why you needed to go into edit mode of your question, or as you've done create an answer with the info.

I'll slide it up to your question as an update.


Thank you for your responses Dan @danj ...

I've read your update.

Let’s FORGOT about the New SSD 1TB Hard Drive I’ve Installed Onto my Laptop. >> X <<

Now, let’s talk about the Old Hard Drive I’ve Pulled Out From My Laptop…

>> The specific problem that I have, is: The Old Hard Drive Won’t Allow me to Change Anything on the my Files to Achieve and Make those files Transferable to make a Backup and then do any software updates.

So, How I could Save the Data Onto a New or Any External HDD Drive, if I Cannot Pull Out that Specific Files / Folders ?

That is the Big and the Real Problem.


Re-read what I wrote... You have two issues here if you are booting up the system using the SSD (High Sierra then you have it to deal with it) If you boot up under Sierra you've solved that problem.

The second one is the file permissions. X owns the file. Are you, X? No! you are Y, Y can't access the file.

Likely, you have a corruption in the files permissions so until you are the EXACT SAME USER you can't access that file. I was moving you to that solution by using Migration Assistant so your SSD was using the EXACT SAME USER accounts.


Frankly, I would just put the HD back into the system and then run Disk Utility to fix the corruption using an external drive which is running the same OS version as the HD is running. If you find that easier!


Exibir mais 11 comentários

Adicionar um comentário

Adicionar a sua resposta

David será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 2

Últimos 7 dias: 17

Últimos 30 dias: 100

Duração total: 13,958