Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Peças e ferramentas

Rear Camera "sometimes" not working after battery replacement

Hi all!

After I replaced the battery of my iPhone 6 I had issues with the rear facing camera (and flash) not working.

Using this forum I found that it could be that the camera got damaged while replacing some parts, therefore I ordered a new camera, replaced it and it worked, great! (Or so I thought).

After using the phone now for two days I found that the camera sometimes works but more often it fails, even weirder: sometimes I am able to use the flash and not the camera and sometimes I'm not able to use either of those...

I am really puzzled by this issue right now, how can it be that the camera randomly switches between working, only using the flash and not working at all?

I was wondering if it was heat related but the phone doesn't seem to be any hotter than before the battery (or camera) replacement. Furthermore the issue does not seem to be related to heat since I am sometimes able to use the camera then the phone is a little hotter and sometimes not able to use the camera when the phone has been idling for a while and therefore not hot at all...

I also tried the DFU reset but that did not change anything.

Answer this question I have this problem too

Is this a good question?

Pontuação 0
Adicionar um comentário

3 Respostas

Do you try resetting the connector? Perhaps it's simply not connected properly and so sometimes connect but sometimes does not.

Was this answer helpful?

Pontuação 0

Comentários:

Yes I did, also tried cleaning the connector with alcohol.

por

How interesting... maybe if its like an off brand camera it just struggles with working properly? Otherwise I have no clue and that's super weird!

por

Haha I know, I'll try contacting the seller...

por

Adicionar um comentário

So I opened my phone again and reconnected the camera again, when I tried putting the protective cover which is on the screen/camera connectors back, I noticed that it was slightly pushing the camera connector down and therefore decided to leave the cover off. Currently the camera is still working and I did not have any issues yet...

Was this answer helpful?

Pontuação 0

Comentários:

So at first it seemed that the camera was having no issues but after a few hours the same issues came back. So still no fix, meanwhile I contacted the camera seller to see if something can be wrong with the part itself.

por

Adicionar um comentário

If the flash does not work, there is a problem with the camera

Sure

If the camera connector is not partially connected, the camera will not work at all!

So these are not contacts

The replacement camera you changed is simply not good, probably used or not original.

Replace the camera everything will work fine.

Note!

The camera connector has loads of components close, be carfully to detach the camera.

Was this answer helpful?

Pontuação 0
Adicionar um comentário

Add your answer

Bouke Regnerus will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 8

All Time: 2,085