Ir para o conteúdo principal

Conserte seus objetos

Direito de executar reparos

Loja

Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

503 Perguntas Visualizar todos

No audio, and no "Internal Speakers" in SystemPrefs>Sound>Output

I am really stumped by this problem, and I'm really hoping you guys can help as I'm pretty sure it's a hardware issue...

Basically, I get no audio from my MacBook Pro Retina 13" Late 2013 A1502 16Gb 2.6GHz - everything else works beautifully as ever with this machine (incl USB & power) apart from the sound.

It has *not* experienced any water damage or drops, but I'm pretty sure this problem started when I plugged in my external power speakers' amp to the headphone jack... just like I did everyday before that, but for some reason this time I didn't get any sound output and the volume feedback was delayed when I tried to turn the volume up/down.

Symptoms:

  • Built-in speakers don't make any sounds.
  • No sound coming from output jack (headphones or external speakers).
  • I see the volume no-access icon (circle with diagonal line through it) when trying to change volume
  • checked System Preferences->Sound settings: nothing showing up under the Output or Input tabs (no "Internal Speakers" showing up)
  • NO RED LIGHT coming from headphone jack... so it's not the optical speaker switch problem most people seem to have.
  • In "system information", when I look in sound hardware... no description for input, output, etc...

I've hunted and hunted all over the internet trying all various suggestions that others have had success with - I've tried all of the following, but still no luck:

I've tried all of the following in the listed order but nothing's changed:

  • repeatedly plugging & unplugging different types audio equipment to the headphones port (including apple headphones)
  • disk utility and run disk repair (no errors)
  • tried PRAM/NVRAM resets (I don't hear the "chime" sound)
  • tried logging in via a new user account
  • tried deleting ~/Library/Preferences:com.apple.systemsound.plist
  • plastic toothpick in the hole
  • looking in the hole with microscope & 1.8mm led to illuminate - can't see anything obstructions in the hole
  • I downloaded and booted the ASD software EFI and OS diagnostics - no errors
  • tried disconnecting battery then rebooting
  • an isopropyl alcohol swabbed q-tip cotton swab

I also went to see a Genius at the Apple Store - they did their tests and said "there's only two options:

  • replace the logic board as we don't replace individual components, or
  • use a USB adapter"

The logic board repair quote was extremely expensive as my warranty is over and the charge probably includes replacing all 16Gb of memory too as it's soldered in; and I said I didn't think that last suggestion was very Apple-like - I'd need to carry around an ugly USB adapter and an external speaker/mic device just to hear sound!

So I'm at a loss and need your help!

Everything else works fine on my computer, so I'm willing to get my multimeter out and start testing hardware but I'm not sure where to start (I/O card / Logic board?).

My logic board # is 820-3476-A

Thanks

Respondido! View the answer Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 17

Comentários:

We have encountered this issue 10 or 15 times and each required component level repair to resolve, the cause has been both spills and drops. Rebuilding this circuit is fairly straight forward if you have the proper tools. Give me the part number for the MLB and I will forward a pic of the schematic and the board view.

por

I found my logic board number under the right-speaker connector (which is under the connector for the I/O board): 820-3476-A

I managed to download the boardview and schematic for this logic board (and also the ones for 820-3536-A which is identical except for the memory layout).

Any suggestions which parts on the logic board I should start testing first? Headphone jack? I/O board? Cirrus audio chipset?

por

Search the schematic for audio, familiarize yourself with where the coronets are on the .brd. The start testing, the measurements that you should have will be relevant to what power rail the audio circuit is on.

por

I have the same problem with my macbook pro retina '15 and still don't know how to fix this problem, can anybody help me?

por

This just happened to me with my newly acquired older macbook, which i have been loving btw, and after a little researching and seeing about the toothpick I first decided to plug in something external to the headphone jack again less toxic and potential damaging...ergo headphones...and to make sure the audio worked thru these and it did...then sure enough thankfully when i removed the headphone plug the internal speaker option returned and digital went away...without havging to find nor stick a toothpick in my computer...happy! hope this might help someone else some day to whom this may occur, without using a toothpick and def without paying someone a bunch of money (unless its me!) for a simple fix...i also expect it will happen again to me... thanks

por

Mostrar mais 18 comentários

Adicionar um comentário

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

18 respostas

Solução escolhida

Sent it in for repair but, after a few hours work, they still couldn't find which component was faulty.

Ended up getting the logicboard replaced

Esta resposta foi útil?

Pontuação 0

Comentários:

I fixed my MacBook Air without sound (hardware test was negative for problems) by opening it up, unplugging and plugging the left and right speaker cables from the motherboard. This was done following iFixit's speaker repair steps as reference. I guess they became loose over time.

por

The problem was the IO flex cable. I bought a Macbook Air 2014 that had liquid spill. I fixed it with replacing the IO board but not the IO flex cable. It has worked fine until now. Suddenly no input or output devices and no sound! I inspected the cable and it had some rusty connectors so I cleaned it and sprayed some contact liquid on the connectors. Everything is back to normal again. But I ordered a new cable just in case.

por

Question:—

My MacBook Pro 15 inches 2012(Intel HD 4000) doesn’t produce sound in the earphones, also sound icon is inactive.. can someone show me which chip to replace on the logic board??

por

I have the same problem, but it's not a MacBook, it's a 2014 Mini. Works perfectly in all other regards. Do I have to open to solve this problem, as was the case with the MacBook Air as reported in this thread?

por

Adicionar um comentário
Pergunta Mais Útil

SMC reset worked fine for me!

Esta resposta foi útil?

Pontuação 8

Comentários:

how do you reset the smc

por

Worked for me as well.

por

Same here! Happens to me like once in a year and SMC reset helps every time.

por

Worked for me also, thank you!

por

Mostrar mais 3 comentários

Adicionar um comentário

Sounds like power has been sent through the port by the amp, damaging the audio circuit.

Check around the bottom right area of the logic board, to see if anything looks burnt. Beyond this, it would need logic board diagnostics and repair, so I would highly suggest sending it to a company who does this, otherwise you will most likely waste time and money on the tools required.

Esta resposta foi útil?

Pontuação 4

Comentários:

>Sounds like power has been sent through the port by the amp, damaging the audio circuit.

Possibly. If that's the case, is there anything that can be done in future to avoid this from happening?

I'll investigate for damaged components around the Headphones jack/Cirrus chip area (I'm assuming that's what you mean by bottom-right area).

por

@capler I would recommend against plugging in anything (speakers, external USB hub, etc) which draws power from the MacBook. I come across ones all the time where this causes a problem with the Mac, especially with powered USB hubs, since they do not usually have an inbuilt protection circuit, to prevent issues like this occurring.

Yes, that's the right area. The Cirrus chip is for the main audio functionality. Feel this area to see if the chip or anything else gets hot, indicating it is shorted to ground.

por

Cirrus chip is very hot when computer is running - to the point of coming close to burning my finger if I hold it on there for 5secs. Is that normal?

por

In fact, U6200 is even hotter - can't touch for a second without burning myself. I take it that's not normal!?

por

Both not normal, either the chip is internally shorted to ground or a component is shorted, then shorting a pin of the chip. Measure the continuity to ground of the pins of the chips, check on schematic whether the pins should be ground or not. Then remove the chip and check the pads to see if the short is gone. If it is, replace the chip and it should be resolved. If the short is not gone, systematically remove the components with a path to ground on the shorted line until you find the short

por

Mostrar mais 6 comentários

Adicionar um comentário

I had similar problem with my MBP A1211. While reconnecting speakers to I/O board didn't helped I tried reconnecting I/O board to logic board. Sound is back.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

I have got the same problem with my mac book pro 2017 13". I have done an SMC reset and everything back to normal again. Turn off mac and do control+option+powerbutton

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

Sounds like you might have damaged the headphone connector. The mac detects if a plug is in the jack and disables the internal speakers if it thinks one is in there. I had a system where the tip of the headphone jack broke off in the connector. It took a bit of work to get the tip out.

Esta resposta foi útil?

Pontuação 0

Comentários:

It if that's the case then shouldn't I see "Headphones" listed in SystemPres>Sound>Output ? Nothing is listed under either Output or Input

por

Yes it would. If that were the problem it would think a headphone was plugged in and display that in the control panel. If it says internal speakers, that is not it. Hope you find the problem. Good Luck.

por

When I don't have headphones plugged in, my system says "Internal Speakers" under Output. As yours shows nothing, you have something more serious going on.

por

But the microphone too isn't working(for me ).

por

Adicionar um comentário

MacBook Pro sin audio Ayuda ...

He venido a este foro tratando de ver si alguien ha tenido este detalle, resulta que tengo una retina MacBook Pro que no tiene audio

En primera instancia, pensé que eran los altavoces, sin embargo, en la configuración de sonido, reconoce los altavoces internos, incluso si conecto un auricular, lo reconoce, pero no suena

Instalé BootCamp para probar con este sistema y hacer lo mismo, lo extraño es que a veces el Spearker hace un sonido, pero cuando se reinicia de nuevo es silencioso, ¿alguien podría ayudarme con lo que podría ser?

Bluetooth funciona sin problemas.

¿Alguna idea?

MacBook Pro with no audio. Help …

I have come to this forum trying to see if anyone has had this detail, it turns out I have a Retina MacBook which has no audio

In the first instance I thought about the speakers, however, in the hardware I recognize the internal speakers even if I connect a headset, it recognizes it but it does not sound

Installed BootCamp to test with this system and do the same thing the odd thing is that sometimes the equipment does sound but when wintering again it is silent, could someone help me what it could be?

Bluetooth works without problems.

Any ideas?

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

fix

blue tooth headphones and then a bluetooth laptop clip on speaker

problem solved i unfortunately split water over mine after having it for two months so i did not want to pay the same price as a new one to fix it anyway, this will fix everything but you will have to use bluetooth from now on

the apple store will let you play around with different options for free to see that works best for you.

make sure you start the media again after starting bluetooth

I did not try a usb audio divice which would probably be even better but might also be an idea

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I wanted to try to reset SMC as described here:

https://support.apple.com/en-ca/HT201295

But I've read section 'Before you reset the SMC' and it helped me.

I've shut down the machine in a different ways and then Internal Speakers (Type: Build in) appears in Sound settings and everything works fine for me.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I have the same problem with my MBP 15" retina late 13”

I just got an email from the service centre today. They told me that the motherboard had to be changed and that it will cost me 7499,-kr which is about $881. Thats not an option that I can accept, I payed 10000,-kr or $1175 for it under one year ago.

I have heard everybody telling me to get a Mac for video editting, so finally I did and this Is what happened after using jack plug with my Spectrum DX7 transmitter for simulator on Liftoff "Drone simulator" to get some stick training for RC drone racing. This is the first time I’ve had a hardware problem on a laptop or a computer except laptop batteries.

Never heard of such a bad product before that can’t handle normal use of a jack plug and get this sort of price tag on the repair. So I guess this was my first and last MacBook!!

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I have the same problem. Macbook Air mid 2012 running High Sierra and ran AHT but found no issues. Under Output it lists Airplay as available but volume icon is greyed out. At the bottom, the Output volume is greyed out and the MUTE button is checked and greyed out. I reseated the internal speaker cable. I tried SMC and PRAM but didn't fix it. I connected headphones to it but didn't trigger anything.

I think the logic board is bad despite everything else working ok.

Esta resposta foi útil?

Pontuação 0

Comentários:

Did your problem got solved?

por

No. I gave it back to the teacher and explained to him the problem and resolution.

por

No, nothing happens, still the same.

por

Adicionar um comentário

I had exactly the same problem. Tried resetting the computer several times and also reset PRAM/NVRAM. Didn’t help.

What resolved the problem all was to actually shut down the computer for a while – instead of only restarting – and then starting it normally. World is a mysterious place.

Esta resposta foi útil?

Pontuação 0

Comentários:

Really interesting. This same thing happened for me, shutting down overnight helped for about 5 minutes, then sound disappeared again. one thing i note: before disappearing, the audio got extremely distorted.

por

Adicionar um comentário

Hi, I had the same problem - No audio, and no internal Speakers in System prefs > Sound > Output.

The solution what helped me was easy:

Press and hold the power button until it shuts down. You'll lose unsaved work in any open applications. Then press the power button again to turn on your Mac.

I tried simply restart before this, but restart wasn’t enough.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

You could try this troubleshooter I found : https://www.youtube.com/watch?v=8yJJzt0W...

Esta resposta foi útil?

Pontuação 0

Comentários:

EVERYONE, I would advise to not download this "troubleshooter". This seems way fishy... User with only one post sending you to a video with comments disabled and asking to download software.

por

Yes very fishy. Stay away.

por

Adicionar um comentário

I have this exact issue with a MBP13 Late 2013. I won't open a new topic because it's very similar. I have a MBP13 Late 2013 that worked flawlessly until recently when sound stopped working. Events are as follows:

  1. MBP13 was running macOS Mojave and updated to Catalina some weeks/months ago. I didn't notice any issues, but some days/weeks after the update, while watching YouTube, the MBP suffered a kernel panic related to coreaudiod. I restarted and I got no audio after that. I got the "no sound" icon when trying to change volume.
  2. I did a search and found the following command to restart coreaudiod: sudo kill ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}' to restart coreaudiod. It worked, but for a short period, after a day or two the audio stopped working again and I got the same “no sound” icon. I tried the command again, but now it didn't work, not only that, inside system preferences > sound > output/input there was no devices listed (internal speaker and mic should be there).
  3. Did NVRAM reset multiple times, didn't work
  4. Did SMC reset multiple times, didn't work
  5. Installed clean macOS Mojave, didn't work
  6. Updated to macOS Catalina, didn't work
  7. Tried plugging in P2 headphones, didn't work
  8. Only bluetooth headphones works
  9. Opened the MBP13 and disconnected and connected the left and right speaker, didn't work

I'm afraid this is a hardware failure, I don't know if it's a logic board issue or speakers issue. If it were only the speakers, the internal mic should still work, right? But, that's not the case as the mic doesn't work either. What do you guys think?

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

I followed the instruction of Abin Jo Abraham.

I held down CONTROL + OPTION + POWER. After it restarted the internal speakers showed up again in my system preferences.

The Apple Support page also suggests an SMC RESET. If you want more details on this just follow the link

https://support.apple.com/en-au/HT201295

“Resetting the system management controller (SMC) can resolve certain issues related to power, battery and other features.”

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

The problem tend to be the Cirrus chip, remove underfill and reflow. If that failed replace chip. Had this issue on 3x820-3476 water damaged and it was the chip every time. It worked with a reflow 1th board.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Hey guys,

I tried a lot of fixes and was quite sure I needed to temper with the logic board until I found this guy’s video:

https://www.youtube.com/watch?v=qTbDgTWh...

Hope it helps.

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Marc será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 163

Últimos 7 dias: 886

Últimos 30 dias: 4,281

Duração total: 154,584