Ir para o conteúdo principal

2, 2.26, 2.53, or 2.66 GHz Core 2 Duo processor

101 Perguntas Visualizar todos

mini A1283 with 256 GB Sandisk X400 SSD

mac mini late 2009 model A1283

I'm upgrading this mac mini with 8 GB RAM and the 256 GB Sandisk X400 SSD. Computer runs fine and boots normally off of original hard drive which has Yosemite installed with 8 GB RAM installed.

I've been trying to get the SSD working and it now has El Capitan with latest updates. I've not been able to get this SSD drive working in the internal slot. System boots normally off the old drive in the internal slot, the system boots El Capitan from the Sandisk SSD if it is put in an external inatek enclosure. System will boot normally with the SSD in the external enclosure, with no drive in the internal slot. So long as the SSD is connected from the external enclosure, everything is fine, system runs El Capitan, and shows 8 GB RAM installed.

If I put the SSD into the internal slot, I get a grey screen. No question mark, no nothing. The only boot key sequence it seems to recognize is reset NVRAM, which I have tried multiple times. No other boot key sequences are recognized. Can't bring up boot manager, can't boot off DVD, nothing. I tried downloading an old EFI firmware update recommended elsewhere. Booted into El Capitan, it says this update is not needed.

I could just run this off the external enclosure, but would prefer to get the SSD working normally in the internal slot.

Any ideas?

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0


Did you format the drive GUID and Mac OS X extended first?


Yes, using Disk Utility from the "Install OS X El Capitan" installer. It currently shows "OS X Extended", partition map: GUID Partition Map, under Disk Utility booted into El Capitan.


Your systems specs: Mac mini 2.66 GHz Core 2 Duo (Late 2009)

Your SSD's specs: SanDisk X400 SSD


I've looked at those Dan, but perhaps I missed the fact that SATA III (this Sandisk X400) is 6 Gb/s and the mini is SATA 3 Gb/s (i.e. SATA II). The Sandisk specs do say the X400 is backward compatible to SATA II and SATA I, and this was the recommended SSD for this system. But perhaps that is the problem?


Adicionar um comentário

1 Resposta

Solução escolhida

From the specs your SSD should be able to run in your system. Your systems SATA ports are SATA II (3.0 Gb/s) and your SanDisk SSD has auto SATA port sense technology so it can match the systems SATA port speed.

Using your HD to boot from see if you can check the systems firmware levels and if needed update it. Here's an Apple TN to help you: About EFI and SMC firmware updates for Intel-based Mac computers. You want to be at the listed level or newer.

Once you've check and if needed corrected the firmware. With the SSD installed plug in your HD using a SATA to USB adapter like this one: Startech 2.5" SATA to USB adapter. Then using pressing the Option key you'll be able to get to the Startup Manager (for reference: Startup key combinations for Mac) this will allow you to boot up under the HD are you then able to see the SSD on your desktop or using by Disk Utility from your HD?

Esta resposta foi útil?

Pontuação 1


I had checked that note Dan,. Hardware Overview shows:

Hardware Overview:

Model Name: Mac mini

Model Identifier: Macmini3,1

Processor Name: Intel Core 2 Duo

Processor Speed: 2.26 GHz

Number of Processors: 1

Total Number of Cores: 2

L2 Cache: 3 MB

Memory: 8 GB

Bus Speed: 1.07 GHz

Boot ROM Version: MM31.00AD.B00

SMC Version (system): 1.35f1

Serial Number (system): YM0062T39G5

Hardware UUID: BCD45848-340A-5F87-AD50-463057501C36

I believe the note recommends: MM31.0081.B06 (EFI 1.2) (this note is from 2009 tho ....) I had downloaded that firmware update:

but when I run the .pkg, an alert pops up, "This computer does not need this update."


... also, keep in mind, once the SSD is put into the internal slot, the boot manager is unavailable. No boot key sequences work aside from the CMD-opt-PR (reset NVRAM). The machine is otherwise completely inert with a blank, grey screen. I've been working with the SSD in an external Inatek housing, which I guess is similar to the startek adapter you mentioned. Everything works fine when it is in the external adapter, I can get to the startup manager, boot keys function normally, the system boots up into El Capitan, etc.


It can be a bit confusing as the versioning is in Hexadecimal so MM31.00AD.B00 is newer than MM31.0081.B06


How did you prep up your SSD? Please list out your steps.


Yes, in any event the 0081.B06 installer quits after showing the alert.

I've been thru all the available software updates on the appstore for El Capitan, hoping that somewhere along the way, a missing firmware update would solve the problem. But the system is fully up-to-date as far as it can go at this point, and the problem persists.

Perhaps this is a blessing in disguise tho. A major reason for putting an SSD in this old box was for the wider thermal range, so that it can be used out in my unheated, un-airconditioned shop. The RAM is upgraded as far as it can go. I guess if I leave the drive in the external housing, at least I can easily replace/upgrade it in the future without having to crack the case.

I'd still like to know why this is so difficult. At the very least, it has wasted a lot of time to get to this unusual state.


Mostrar mais 5 comentários

Adicionar um comentário

Adicionar a sua resposta

eric Ogata será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 3

Duração total: 409