Ir para o conteúdo principal

Replaced LCD Assembly, Fingerprint messed up.

Good Evening from Rainy Cali!

I got an iPhone 6, shattered screen, visible LCD, all features working as intended. otherwise. I replaced the LCD Assembly with one from Laptopscreen.com

https://www.laptopscreen.com/English/mod...

I gently removed the existing Home Button and Metal Plate-Cable Combo, transferred them to the new LCD Assembly, and reassembled, along with the Cams, etc.

The phone works with two exceptions: both involve a Wonky Fingerprint button.

A) The Fingerprint Sensor does not respond. Fingerprints are not found on the phone, attempting to make new ones instantly goes to "Failed, there was an error enrolling fingerprints."

B) The Home button cannot wake up the phone and bring it to the lock screen, But once unlocked, the home button works for changing between apps, getting the Apple Pay card to come up (but not pay, no fingerprint.)

Anyone heard of this crap before?

PS...I was Using a 24x24 Antistatic Mat, a Wrist Strap, both connected to a Banana Junction, which then runs to the Center Screw of the Electrical Wall Outlet using Size 5 Ring terminals on 12 gauge wire, using the ESD safe Blacksticks, and wearing two black Nitrile Gloves, dressed wearing all cotton dickies shirt, Carhart cotton socks, and Bamboo-toe shoes, while listening to the Lord of the Rings Pandora station - All the Apple service tech requirements were met, to the best of my knowledge. ;)

Respondido! Ver a resposta Também tenho esse problema

Esta pergunta é pertinente?

Pontuação 0

Comentários:

Is this for 6 or 6S?

por

Adicionar um comentário

2 respostas

Solução escolhida

UPDATE: The problem has been solved. The Flex Cable that goes from the Logic Board to the Fingerprint/Home Button was successfully replaced, with minimal fuss, and it solved the problem.

Here's the part that solved it:

http://www.amazon.com/gp/product/B00XN9Z...

That flex cable is SO delicate, it's not even funny.

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário
Pergunta Mais Útil

Was the previous screen cracked around the home button? The reason I ask is that I have had a similar problem a while back and found it to be small shards or glass that where actually in-bedded in the backside of the home button that mates with the backing plate that holds the home button in place . Dont know how I managed it but it did cause the problem and once removed had my joy back . Give it a look and hope this helps

Esta resposta foi útil?

Pontuação 1
Adicionar um comentário

Adicionar a sua resposta

Kevin McCartney será eternamente grato(a).
Exibir estatísticas:

Últimas 24 horas: 0

Últimos 7 dias: 0

Últimos 30 dias: 0

Duração total: 134