Not charging, MagSafe led is green, working only with charged battery

Hi everyone,

I have a Macbook Pro 13" Early 2011, problem is "Battery is not charging".

When I connect MagSafe adapter, green led appears and no amber/orange led turns on.

I removed the battery and plugged into another Macbook Pro, It seems charging and functioning normally. I have fully charged the battery on working Macbook Pro and plugged back another Macbook Pro. System is starting normally, but "Battery is not charging" label appears on top of screen. MagSafe led is green and battery is discharging. When the battery is completely discharged, there is no way to power on the unit. Only working with charged battery.

I did SMC, PRAM reset. No luck.

I think it's a logic board problem.

Please help. (I have electronics skills.)

Block Image

Block Image

Block Image

Power.pdf

Update (11/18/2015)

Battery is charging perfectly on working Macbook Pro.

Block Image

Block Image

I measured current sense resistors with multimeter on faulty Macbook Pro. One of them about 2.5ohms, another is about 50ohms. Are these correct?

Block Image

Update (11/19/2015)

R7052 current sense resistor was causing the problem. I've measured it as 50 ohms before. I've replaced it with 0 ohms. Problem SOLVED!

Respondido! View the answer Também tenho esse problema

Esta é uma boa pergunta?

Pontuação 1

Comentários:

Bravo... It workes for me . Mine was macbook pro early 2011 .. Amd board was 820-2565A.. I think mine board was damaged due to power surge because after that i order magsafe adapter which was damaged and my macbook works for some few days because of remaining charge in battery.. Then i order new battery cos i thought it might be due to battery failures.. With new battery it again works for sometime and the same issue .. Then only i got to know that the issue is of charging not of SMC, PRAm, charger or battery.. I bypassed the resistor with screw and kudos.. It starts charging and orange light appeared on magsafe port.. Thank you so much dear.. You save the day..

por

Adicionar um comentário
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3 Soluções

Solução escolhida

Yes this is a board problem. Most commenly caused by using non-OEM power adapters or from a power surge. Do you have schematics or tools to troubleshoot the motherboard? What is the 820-#### number on the board?

Esta resposta foi útil?

Pontuação 2

Comentários:

Unfortunately I don't have schematics. I've some tools like multimeter, soldering iron, hot air station. Board number is 820-2936-B

por

That's the same board I had an identical issue on myself as well. Try looking around online for the schematic (they're out there but i'm not allowed to post a direct link). Once you get ahold of it check along the onewire / DC-IN circuit and look for any possible shorts. Wish you luck man!

por

Dear Matt,

I found the schematics on the Internet. Problem is at current resistors.

I've measured 50ohms at R7052. It has to be 0ohms. I've replaced it, problem SOLVED! Works like charm! :)

And I found another problem at one of the USB ports. One of them sometimes isn't working. Cracked L4610 was causing the problem. I don't have L4610 at the moment. I will order it on Digikey.

Thank you for your help!

por

If this answer solved your problem, please accept it so others can learn from it, Thanks

por

Glad to be of help!

por

Adicionar um comentário

Are you getting a red or black X on the battery icon? I'd download and run Coconut Battery to get a better idea of what is happening with the battery and let us know your results.

http://www.coconut-flavour.com/coconutba...

Esta resposta foi útil?

Pontuação 1

Comentários:

No. There is no red or black X on the battery icon. See the screenshots.

por

Run Coconut on the battery from the machine that you charged it on. Switch Mag-Safe power adapters.

por

I did. Please see the screenshots on my next post. It's charging perfectly.

por

Adicionar um comentário

Hi!

I have the same problem.

I was able to measure the R7052 sense resistor and it has around 30+ ohms.

I wonder about the specifications of that resistor though.

I know it should have zero ohms, but that is all I know about it.

Can you be so kind and specify the size/name/material/etc for that?

Found a big list of options...

Or maybe you have a link for it on Digikey or somewhere else?

I really don't want to use a wire.

Thanks!

Esta resposta foi útil?

Pontuação 0
Adicionar um comentário

Adicionar a sua resposta

Hamit Yanik será eternamente grato(a).
Visualizar Estatísticas:

Últimas 24 horas: 5

Últimos 7 dias: 19

Últimos 30 dias: 93

Todo: 1,979